Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366138 - Reduce the frequency of logged number of running VMs
Summary: Reduce the frequency of logged number of running VMs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.0.2.6
Hardware: Unspecified
OS: Unspecified
high
low vote
Target Milestone: ovirt-4.0.4
: 4.0.4
Assignee: Arik
QA Contact: Nisim Simsolo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-11 07:47 UTC by Arik
Modified: 2016-09-26 12:34 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-26 12:34:25 UTC
oVirt Team: Virt
rule-engine: ovirt-4.0.z+
mgoldboi: planning_ack+
michal.skrivanek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 62234 master MERGED core: log num of running vms only upon change 2016-08-11 10:41:00 UTC
oVirt gerrit 62321 ovirt-engine-4.0 MERGED core: log num of running vms only upon change 2016-08-14 19:21:49 UTC

Description Arik 2016-08-11 07:47:01 UTC
Description of problem:
In order to investigate bz 1339291 we added a message that logs the number of running VMs on each host in every statistics monitoring cycle. This floods the log when there is a relatively high number of host in the environment.


Actual results:
Many periodic log in the form:
Fetched <num of vms> VMs from VDS <vds id>
that make it harder to resolve important information from the log file

Expected results:
Reduce the number of log messages

Additional info:
This information could be useful in some cases, therefore we should not remove it completely or throw it to debug mode. Instead, we can print it only upon change

Comment 1 Arik 2016-08-17 05:54:50 UTC
*** Bug 1367519 has been marked as a duplicate of this bug. ***

Comment 2 Nisim Simsolo 2016-09-07 11:40:23 UTC
Verified: rhevm-4.0.4-0.1.el7ev.noarch

Number of running VMs is now logged upn change. for example,
Run VM, and observe engine.log:
2016-09-07 14:38:24,138 INFO  [org.ovirt.engine.core.vdsbroker.monitoring.VmsStatisticsFetcher] (DefaultQuartzScheduler10) [72c91f3d] Fetched 3 VMs from VDS '377adb6d-4206-4124-a8f6-3a8c23b03f79'


Note You need to log in before you can comment on or make changes to this bug.