Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366114 - [abrt] bodhi-client: sessions.py:518:post:TypeError: request() got an unexpected keyword argument 'req_params'
Summary: [abrt] bodhi-client: sessions.py:518:post:TypeError: request() got an unexpec...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: bodhi
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Randy Barlow
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:168cabbe0a782b93e68757cdaf5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-11 05:41 UTC by Vít Ondruch
Modified: 2016-10-19 10:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-18 05:02:43 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2016-08-11 05:41 UTC, Vít Ondruch
no flags Details
File: dso_list (deleted)
2016-08-11 05:41 UTC, Vít Ondruch
no flags Details
File: environ (deleted)
2016-08-11 05:41 UTC, Vít Ondruch
no flags Details

Description Vít Ondruch 2016-08-11 05:41:04 UTC
Version-Release number of selected component:
bodhi-client-0.9.12.2-5.fc25

Additional info:
reporter:       libreport-2.7.2
cmdline:        /usr/bin/python2 -tt /usr/bin/bodhi -o rubygem-activemodel-serializers-xml-1.0.1-1.fc25 -N 'Needed for rubygem-activeresource.'
executable:     /usr/bin/bodhi
kernel:         4.7.0-2.fc26.x86_64
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           Python
uid:            16025

Truncated backtrace:
sessions.py:518:post:TypeError: request() got an unexpected keyword argument 'req_params'

Traceback (most recent call last):
  File "/usr/bin/bodhi", line 537, in <module>
    main()
  File "/usr/bin/bodhi", line 433, in main
    }, auth=True)
  File "/usr/lib/python2.7/site-packages/fedora/client/openidbaseclient.py", line 240, in send_request
    output = func(method, **kwargs)
  File "/usr/lib/python2.7/site-packages/fedora/client/openidbaseclient.py", line 78, in _decorator
    output = func(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/fedora/client/openidbaseclient.py", line 195, in _authed_post
    response = self._session.post(url, params=params, data=data, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 518, in post
    return self.request('POST', url, data=data, json=json, **kwargs)
TypeError: request() got an unexpected keyword argument 'req_params'

Local variables in innermost frame:
url: 'https://bodhi.fedoraproject.org/override/save'
json: None
data: None
self: <requests.sessions.Session object at 0x7f95f80e9f50>
kwargs: {'req_params': {'notes': 'Needed for rubygem-activeresource.', 'builds': 'rubygem-activemodel-serializers-xml-1.0.1-1.fc25', 'expiration': '08/14/2016'}, 'params': None, 'timeout': 300}

Comment 1 Vít Ondruch 2016-08-11 05:41:10 UTC
Created attachment 1189887 [details]
File: backtrace

Comment 2 Vít Ondruch 2016-08-11 05:41:11 UTC
Created attachment 1189888 [details]
File: dso_list

Comment 3 Vít Ondruch 2016-08-11 05:41:13 UTC
Created attachment 1189889 [details]
File: environ

Comment 4 Randy Barlow 2016-10-18 05:01:22 UTC
Hello!

I have recently become the primary caretaker of Bodhi and I've inherited a number of issues related to bodhi 0.9. I wanted to be forthcoming with you that it will be difficult for me to fix issues with bodhi 0.9 while also pressing forward with bodhi 2, especially since I do not have any familiarity with the bodhi 0.9 codebase. I'm happy to keep this bug open to track the problem, but I would also encourage you to please test the bodhi 2 client (currently available in Rawhide and Copr[0]). Unfortunately, the bodhi 2 client is not backwards compatible with bodhi 0.9, so at this time I only plan for bodhi 2 to be released with Fedora 26 and EPEL 7 (with special permission from the EPEL SC).

Here are some options you could pursue for this issue:

0) Write a patch for me that can be applied with the spec file. If you are willing to take the time to learn the bodhi 0.9 code, write a patch, and test it, I am willing to accept patches to be applied during build.
1) Use Rawhide.
2) Install bodhi 2 from my Copr[0].

I apologize as I understand that this is probably disappointing news for you to hear, but I thought it would be better to be forthcoming than to let the bug languish. I appreciate your understanding!


[0] https://copr.fedorainfracloud.org/coprs/bowlofeggs/bodhi/

Comment 5 Randy Barlow 2016-10-18 05:02:43 UTC
I just noticed that this one was reported against rawhide, which has a re-written CLI. I'm going to close this as fixed with the assumption that the rewrite wouldn't have the exact same issue. Feel free to reopen if you can reproduce with 2.2.4 or newer.

Comment 6 Vít Ondruch 2016-10-18 11:09:07 UTC
$ bodhi overrides save --notes "Just test." rubygem-httparty-0.14.0-1.fc25

Worked just fine using bodhi-client-2.2.4-1.fc26.noarch. Not sure how to expire the override from the CLI though :/

Comment 7 Randy Barlow 2016-10-18 19:31:56 UTC
Hello Vit! I also don't see a way to expire an existing one from the CLI - would you like to file an RFE for that?

https://github.com/fedora-infra/bodhi/issues/new

I think the web UI can do it in the meantime.

Comment 8 Vít Ondruch 2016-10-19 10:12:21 UTC
Just for the reference:

https://github.com/fedora-infra/bodhi/issues/1049


Note You need to log in before you can comment on or make changes to this bug.