Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366092 - Subscriptions page should differentiate between not installed and insufficient privileges
Summary: Subscriptions page should differentiate between not installed and insufficien...
Keywords:
Status: CLOSED DUPLICATE of bug 1442540
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cockpit
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: pre-dev-freeze
: ---
Assignee: Peter
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: ovirt-node-ng-platform ovirt-node-ng-43-el76-platform
TreeView+ depends on / blocked
 
Reported: 2016-08-11 03:10 UTC by Wei Wang
Modified: 2018-01-23 12:32 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-23 12:32:51 UTC


Attachments (Terms of Use)
picture (deleted)
2016-08-11 03:10 UTC, Wei Wang
no flags Details

Description Wei Wang 2016-08-11 03:10:16 UTC
Created attachment 1189874 [details]
picture

Description of problem:
The user prompt is wrong in subscription page after login with non-root account.


Version-Release number of selected component (if applicable):
RHVH-7.2-20160804.0-RHVH-x86_64-dvd1.iso
imgbased-0.7.4-0.1.el7ev.noarch
cockpit-0.114-2.el7.x86_64
cockpit-ovirt-dashboard-0.10.6-1.3.4.el7ev.noarch


How reproducible:
100%


Steps to Reproduce:
1. Install RHVH-7.2-20160804.0-RHVH-x86_64-dvd1.iso (default ks file)
2. Login cockpit website hostIP:9090 with root account
3. Create an non-root account, then log out
4. Login with the non-root account
5. Select the "subscriptions" page, then checking the user prompt


Actual results:
The user prompt is wrong in subscription page after login with non-root account.


Expected results:
The user prompt should tell user the non-root account cannot use subscription functionality.



Additional info:
Subscription-manager is installed automatically after installing the RHVH.

Comment 2 Dominik Perpeet 2016-08-11 07:53:59 UTC
Good catch, this should be stated more clearly. I will look into the different cases.

Comment 4 Martin Pitt 2018-01-23 12:32:51 UTC

*** This bug has been marked as a duplicate of bug 1442540 ***


Note You need to log in before you can comment on or make changes to this bug.