Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366040 - Specifying components in hammer admin logging does not work
Summary: Specifying components in hammer admin logging does not work
Keywords:
Status: CLOSED DUPLICATE of bug 1366171
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 20:40 UTC by jcallaha
Modified: 2016-08-15 18:27 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-15 18:27:59 UTC


Attachments (Terms of Use)

Description jcallaha 2016-08-10 20:40:48 UTC
Description of problem:
When trying to specify a valid component with the hammer admin logging command, none are accepted. 

[root@rhsm-qe-1 ~]# hammer admin logging -d -c rails
Error: Unknown component provided, use --list to find them

[root@rhsm-qe-1 ~]# hammer admin logging -d --components rails
Error: Unknown component provided, use --list to find them

Version-Release number of selected component (if applicable):
Satellite 6.2.1 Snap 1.2

How reproducible:
Always

Steps to Reproduce:
1. enable or disable debug logging, specifying at least one listed component.

Actual results:
[root@ibm-x3550m3-10 ~]# hammer admin logging -d -c postgresql
Error: Unknown component provided, use --list to find them
[root@ibm-x3550m3-10 ~]# hammer admin logging -d -c=rails
Error: Unknown component provided, use --list to find them
[root@ibm-x3550m3-10 ~]# hammer admin logging -d -c proxy
Error: Unknown component provided, use --list to find them
[root@ibm-x3550m3-10 ~]# hammer admin logging -d -c puppet
Error: Unknown component provided, use --list to find them
[root@ibm-x3550m3-10 ~]# hammer admin logging -d -c dhcp
Error: Unknown component provided, use --list to find them
[root@ibm-x3550m3-10 ~]# hammer admin logging -d -c named
Error: Unknown component provided, use --list to find them
[root@ibm-x3550m3-10 ~]# hammer admin logging -d -c tftp
Error: Unknown component provided, use --list to find them
[root@ibm-x3550m3-10 ~]# hammer admin logging -d -c qpidd
Error: Unknown component provided, use --list to find them
[root@ibm-x3550m3-10 ~]# hammer admin logging -d -c tomcat
Error: Unknown component provided, use --list to find them
[root@ibm-x3550m3-10 ~]# hammer admin logging -d -c pulp
Error: Unknown component provided, use --list to find them
[root@ibm-x3550m3-10 ~]# hammer admin logging -d -c virt-who
Error: Unknown component provided, use --list to find them

Expected results:
The command accepts all components listed with hammer admin logging -l

Additional info:
# hammer admin logging -l
-----------|-------------------------------------|-------------------------------------
COMPONENT  | AUTO-DETECTED BY EXISTENCE OF       | DESTINATIONS                        
-----------|-------------------------------------|-------------------------------------
postgresql | /var/lib/pgsql/data/postgresql.conf | syslog /var/lib/pgsql/data/pg_log/  
rails      | /etc/foreman/settings.yaml          | /var/log/foreman/production.log     
proxy      | /etc/foreman-proxy/settings.yml     | /var/log/foreman-proxy/proxy.log    
puppet     | /etc/puppet/puppet.conf             | /var/log/puppet/masterhttp.log      
dhcpd      | /etc/dhcp/dhcpd.conf                | syslog /var/log/dhcpd-debug.log     
named      | /etc/named.conf                     | syslog                              
tftp       | /etc/xinetd.d/tftp                  | syslog                              
qpidd      | /etc/qpid/qpidd.conf                | syslog                              
tomcat     | /etc/candlepin/candlepin.conf       | /var/log/candlepin/ /var/log/tomcat/
pulp       | /etc/pulp/server.conf               | syslog /var/log/pulp-debug.log      
virt-who   | /etc/sysconfig/virt-who             | syslog                              
-----------|-------------------------------------|-------------------------------------

Comment 1 jcallaha 2016-08-15 18:27:59 UTC

*** This bug has been marked as a duplicate of bug 1366171 ***


Note You need to log in before you can comment on or make changes to this bug.