Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366035 - GNOME Screenshotter hangs after some captures
Summary: GNOME Screenshotter hangs after some captures
Keywords:
Status: CLOSED DUPLICATE of bug 1353321
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-screenshot
Version: 24
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 20:07 UTC by David Strauss
Modified: 2016-08-16 11:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-16 11:58:35 UTC


Attachments (Terms of Use)
strace of GNOME Screenshot (deleted)
2016-08-10 20:07 UTC, David Strauss
no flags Details
GDB Backtrace at the time of Hangup (deleted)
2016-08-10 20:07 UTC, David Strauss
no flags Details

Description David Strauss 2016-08-10 20:07:19 UTC
Created attachment 1189791 [details]
strace of GNOME Screenshot

Description of problem:
After selecting an area to capture, GNOME Screenshot often hangs for 10-30 seconds before showing the screen that allows you to save the image or copy it to the clipboard.

Version-Release number of selected component (if applicable):
[straussd@titan ~]$ dnf info gnome-screenshot
Last metadata expiration check: 21 days, 23:06:09 ago on Tue Jul 19 13:49:27 2016.
Installed Packages
Name        : gnome-screenshot
Arch        : x86_64
Epoch       : 0
Version     : 3.20.1
Release     : 1.fc24
Size        : 855 k
Repo        : @System
From repo   : updates
Summary     : A screenshot utility for GNOME
URL         : http://www.gnome.org
License     : GPLv2+
Description : gnome-screenshot lets you take pictures of your screen.

How reproducible:
Every time I take a screenshot from Slack running in Chrome or Firefox.

Steps to Reproduce:
1. Log in with a Wayland session. (Not sure if this is relevant, but it's what I do.)
2. Load a busy channel in Slack. (For whatever reason, this seems to be relevant. Screenshots of, say, Bugzilla don't create any delay.)
3. Use GNOME Screenshot to snap part of the window. (Snapping the whole window doesn't cause a delay, either.)

Actual results:
Long delay before GNOME Screenshot steals my focus and then allows me to save the file.

Expected results:
Nearly instant option to save the file.

Additional info:
The strace is truncated and only contains data up to the hang (on the mmap call).

Comment 1 David Strauss 2016-08-10 20:07:53 UTC
Created attachment 1189792 [details]
GDB Backtrace at the time of Hangup

Comment 2 M. Edward (Ed) Borasky 2016-08-12 04:23:15 UTC
I think this is happening to me ... Fedora 24, updates-testing enabled, X, not Wayland. I'm not sure what's happening but gnome-screenshot is showing 100% CPU and I don't get a dialog to do the capture.

Comment 3 Rui Matos 2016-08-16 11:58:35 UTC

*** This bug has been marked as a duplicate of bug 1353321 ***


Note You need to log in before you can comment on or make changes to this bug.