Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366026 - Clicking on Review/Openshift tab loses changed hypervisor selection
Summary: Clicking on Review/Openshift tab loses changed hypervisor selection
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: ---
Assignee: cchase
QA Contact: Thom Carlin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 19:28 UTC by cchase
Modified: 2016-09-13 16:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:36:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description cchase 2016-08-10 19:28:01 UTC
Description of problem:
From RHV hypervisor selection, clicking on the OpenShift or Review tab loses your modified selection.


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Create at least 2 discovered hosts to use as hypervisors
2. Create a rhev deployment
3. Choose a hypervisor (ex. hypervisor1) and progress to review screen.
4. From review screen click on the selected hypervisor to take you back to the hypervisor selection screen.
5. Choose the other hypvervisor (ex. hypervisor2).
6. Click the Review tab.

Actual results:
The selection will revert back to the original selection (ex. hypervisor1) losing the user's new choice. At the review screen that original selection is still chosen.


Expected results:
The new selection (ex. hypervisor2) will be persisted.  The review screen will display the newly selected hypervisor for deployment.

Additional info:

Comment 2 cchase 2016-08-11 18:20:34 UTC
https://github.com/fusor/fusor/pull/1150

Retains the updated hypvervisor selection.

Comment 4 Thom Carlin 2016-09-01 14:08:52 UTC
Requires 3 discovered hosts:
* Engine
* Hypervisor1
* Hypervisor2

2. RHV + OpenShift deployment

3. In "RHV > Hypervisor", select hypervisor 1 only

4. From "Review > Installation Review" page, select "2. RHV"

5. Deselect hypervisor 1, select hypervisor 2

New selection [hypervisor 2] is displayed

Similarly for moving out of deployment, then Deployment, then navigating to 5. Review...

VERIFIED in QCI-1.0-RHEL-7-20160830.t.0

Comment 6 errata-xmlrpc 2016-09-13 16:36:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.