Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366023 - digikam has broken dependencies
Summary: digikam has broken dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: digikam
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F25AlphaFreezeException
TreeView+ depends on / blocked
 
Reported: 2016-08-10 19:02 UTC by Rex Dieter
Modified: 2016-08-19 02:26 UTC (History)
7 users (show)

Fixed In Version: digikam-5.1.0-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-19 02:26:03 UTC


Attachments (Terms of Use)

Description Rex Dieter 2016-08-10 19:02:08 UTC
digikam has broken dependencies in the rawhide tree:
On x86_64:
        digikam-5.0.0-2.fc25.x86_64 requires libmarblewidget-qt5.so.24()(64bit)
On i386:
        digikam-5.0.0-2.fc25.i686 requires libmarblewidget-qt5.so.24
On armhfp:
        digikam-5.0.0-2.fc25.armv7hl requires libmarblewidget-qt5.so.24
On x86_64:
        digikam-libs-5.0.0-2.fc25.x86_64 requires libmarblewidget-qt5.so.24()(64bit)
On i386:
        digikam-libs-5.0.0-2.fc25.i686 requires libmarblewidget-qt5.so.24
On armhfp:
        digikam-libs-5.0.0-2.fc25.armv7hl requires libmarblewidget-qt5.so.24
Please resolve this as soon as possible.


A new digikam build landed shortly after marble, but not before the alpha freeze cutoff.

Comment 1 Fedora Update System 2016-08-10 19:02:56 UTC
digikam-5.1.0-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-10e0e2215c

Comment 2 Fedora Blocker Bugs Application 2016-08-10 19:04:08 UTC
Proposed as a Freeze Exception for 25-beta by Fedora user rdieter using the blocker tracking app because:

 Fixes broken dependencies on kde spin

Comment 3 Rex Dieter 2016-08-10 19:04:51 UTC
Oops, accidentally submitted for beta breeze instead of alpha.

Comment 4 Adam Williamson 2016-08-15 17:12:24 UTC
rex: you can fix it like this :)

Comment 5 Geoffrey Marr 2016-08-15 19:27:26 UTC
Discussed during the 2016-08-15 blocker review meeting: [1]

The decision to classify this bug as an AcceptedFreezeException (Alpha) was made as it is always good to fix dependency issues in the repositories. It is confirmed that this bug does not affect the KDE live images.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-08-15/f25-blocker-review.2016-08-15-16.00.txt

Comment 6 Fedora Update System 2016-08-19 02:25:56 UTC
digikam-5.1.0-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.