Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1366014 - Reload RHV self-hosted disables deploy button and tabs.
Summary: Reload RHV self-hosted disables deploy button and tabs.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: ---
Assignee: cchase
QA Contact: Thom Carlin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 18:14 UTC by cchase
Modified: 2016-09-13 16:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:36:01 UTC


Attachments (Terms of Use)
Review Page with disabled tabs/button. (deleted)
2016-08-10 18:14 UTC, cchase
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description cchase 2016-08-10 18:14:43 UTC
Created attachment 1189780 [details]
Review Page with disabled tabs/button.

Description of problem:
Reloading the review page with a deployment with RHV self-hosted loses validation info, disables the deploy button, and disables tabs after RHV.


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Create a new RHEV deployment
2. Select self-hosted
3. Progress to the review installation page
4. Reload the browser

Actual results:
Deploy button is disabled. Tabs after RHV are disabled.  By going back to the RHV tab, all the tabs will re-enable and the deploy button will be enabled if navigating to the review page.


Expected results:
State of deployment should still be the same (tabs and deploy button should still be enabled).  Should be allowed to deploy.


Additional info:  Direct navigation will also result in the same behavior.

Comment 1 cchase 2016-08-10 18:18:16 UTC
https://github.com/fusor/fusor/pull/1145

Reload should now properly load the RHEV self-hosted validation and not disable tabs/deploy button

Comment 4 Thom Carlin 2016-09-01 13:48:56 UTC
Step 3. "review installation page" is actually "Review > Installation Review"

VERIFIED in QCI-1.0-RHEL-7-20160830.t.0 with Chrome:
* Shift-Reload
* Reload

Tabs and Deploy buttons remain enabled

Comment 6 errata-xmlrpc 2016-09-13 16:36:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.