Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365991 - find.pl missing from perl package on RHEL 7
Summary: find.pl missing from perl package on RHEL 7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: perl
Version: 7.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: perl-maint-list
QA Contact: Martin Kyral
Lenka Špačková
URL:
Whiteboard:
Depends On:
Blocks: 1367691
TreeView+ depends on / blocked
 
Reported: 2016-08-10 17:19 UTC by Deepu K S
Modified: 2016-11-04 00:16 UTC (History)
6 users (show)

Fixed In Version: perl-5.16.3-291.el7
Doc Type: Release Note
Doc Text:
A new _perl-Perl4-CoreLibs_ subpackage contains previously removed files The `provides` tag was incorrectly set for previously deprecated files that were no longer included in the _perl_ package. To fix this bug, these files have been backported from the previous version of Perl and are now provided by a newly created _perl-Perl4-CoreLibs_ subpackage.
Clone Of:
Environment:
Last Closed: 2016-11-04 00:16:28 UTC


Attachments (Terms of Use)
Clean up list of provided files (deleted)
2016-08-11 07:10 UTC, Jitka Plesnikova
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2191 normal SHIPPED_LIVE perl bug fix update 2016-11-03 13:19:19 UTC
Red Hat Bugzilla 1366724 None None None Never

Description Deepu K S 2016-08-10 17:19:01 UTC
Description of problem:
Files find.pl, getopt.pl and getops.pl missing from perl package even though it is listed under perl rpm provides
These files were present in RHEL 6, however it seems to be discontinued with RHEL 7. However, checking perl package 'provides' shows these files as included.

# rpm -q --provides perl|egrep '\(getopts?.pl|find.pl'
perl(find.pl)
perl(getopt.pl)
perl(getopts.pl)

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 7.2
perl-5.16.3-286.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Check the perl provides list. It shows these files.
2. Checking the package file list doesn't have this included.
3.

Actual results:
# rpm -q --provides perl|egrep '\(getopts?.pl|find.pl'
perl(find.pl)
perl(getopt.pl)
perl(getopts.pl)

# rpm -ql perl|egrep 'getopt|find.pl'
#

Expected results:
Include the files in RHEL 7.

# rpm -ql perl|egrep 'getopt|find.pl'
/usr/share/perl5/find.pl
/usr/share/perl5/getopt.pl
/usr/share/perl5/getopts.pl
/usr/share/perl5/newgetopt.pl

Additional info:

Comment 1 Jitka Plesnikova 2016-08-11 06:57:53 UTC
The utils wre deprecated in Perl 5.12.0. More information see on page

http://search.cpan.org/~rjbs/perl-5.16.3/pod/perl5120delta.pod#Deprecations

Look for "Numerous Perl 4-era libraries"


They were removed from core in Perl 5.16.0 and could be found on CPAN as Perl4::CoreLibs.

http://search.cpan.org/~rjbs/perl-5.16.3/pod/perl5160delta.pod#Removed_Modules_and_Pragmata


We forgot to remove the utils from perl provides.

Comment 2 Jitka Plesnikova 2016-08-11 07:10:48 UTC
Created attachment 1189927 [details]
Clean up list of provided files

Comment 6 Jitka Plesnikova 2016-08-16 12:12:15 UTC
How to test:

Check that the deprecated files below are not listed in perl-5.16.3-290.el7 provides:
perl(abbrev.pl)
perl(assert.pl)
perl(bigfloat.pl)
perl(bigint.pl)
perl(bigrat.pl)
perl(cacheout.pl)
perl(complete.pl)
perl(ctime.pl)
perl(dotsh.pl)
perl(exceptions.pl)
perl(fastcwd.pl)
perl(find.pl)
perl(finddepth.pl)
perl(flush.pl)
perl(ftp.pl)
perl(getcwd.pl)
perl(getopt.pl)
perl(getopts.pl)
perl(hostname.pl)
perl(importenv.pl)
perl(look.pl)
perl(newgetopt.pl)
perl(open2.pl)
perl(open3.pl)
perl(pwd.pl)
perl(shellwords.pl)
perl(stat.pl)
perl(syslog.pl)
perl(tainted.pl)
perl(termcap.pl)
perl(timelocal.pl)
perl(validate.pl)


Current result should be:
$ rpm -qp --provides perl-5.16.3-290.el7.x86_64.rpm | grep '\.pl'
perl(bytes_heavy.pl)
perl(dumpvar.pl)
perl(perl5db.pl)
perl(utf8_heavy.pl)

Comment 10 Jitka Plesnikova 2016-08-18 10:46:44 UTC
How to test:

Check that the deprecated files below are provided by perl-Perl4-CoreLibs-0.001-291.el7:
perl(abbrev.pl)
perl(assert.pl)
perl(bigfloat.pl)
perl(bigint.pl)
perl(bigrat.pl)
perl(cacheout.pl)
perl(complete.pl)
perl(ctime.pl)
perl(dotsh.pl)
perl(exceptions.pl)
perl(fastcwd.pl)
perl(find.pl)
perl(finddepth.pl)
perl(flush.pl)
perl(getcwd.pl)
perl(getopt.pl)
perl(getopts.pl)
perl(hostname.pl)
perl(importenv.pl)
perl(look.pl)
perl(newgetopt.pl)
perl(open2.pl)
perl(open3.pl)
perl(pwd.pl)
perl(shellwords.pl)
perl(stat.pl)
perl(syslog.pl)
perl(tainted.pl)
perl(termcap.pl)
perl(timelocal.pl)
perl(validate.pl)

The only removed provides is perl(ftp.pl). The file was also missing in Perl 5.10.1.

Comment 16 Jitka Plesnikova 2016-09-27 13:44:58 UTC
It looks good.

Comment 18 errata-xmlrpc 2016-11-04 00:16:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2191.html


Note You need to log in before you can comment on or make changes to this bug.