Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365959 - RHEVM Default Credentials become invalid after sometime when C&U credentials are added
Summary: RHEVM Default Credentials become invalid after sometime when C&U credentials ...
Keywords:
Status: CLOSED DUPLICATE of bug 1361258
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: GA
: 5.7.0
Assignee: lgalis
QA Contact: Nandini Chandra
URL:
Whiteboard: provider:rhev
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 15:19 UTC by Nandini Chandra
Modified: 2016-08-24 02:53 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-19 16:33:34 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nandini Chandra 2016-08-10 15:19:12 UTC
Description of problem:
------------------------
RHEVM Default Credentials become invalid after sometime when C&U credentials are added.

Here's a snippet from evm.log.It looks like the provider becomes unreachable for some reason.

This issue doesn't occur when C&U credentials have not been added for a RHEVM provider.

[----] I, [2016-08-09T16:21:12.878213 #25371:11a5990]  INFO -- : MIQ(ManageIQ::Providers::Redhat::InfraManager#connect) Using stored API path '/api'.

[----] E, [2016-08-09T16:21:12.940663 #25371:11a5990] ERROR -- : <RHEVM> Ovirt::Service#resource_get: class = Errno::EHOSTUNREACH, message=No route to host - connect(2) for "10.zz.xx.yy" port 5000, URI=https://10.zz.xx.yy:5000/api

[----] W, [2016-08-09T16:21:12.941098 #25371:11a5990]  WARN -- : MIQ(ManageIQ::Providers::Redhat::InfraManager#authentication_check_no_validation) type: ["default"] for [1] [nested-rhevm35] Validation failed: invalid, Login failed due to a bad username or password.

[----] W, [2016-08-09T16:21:12.941553 #25371:11a5990]  WARN -- : MIQ(AuthUseridPassword#validation_failed) [ExtManagementSystem] [1], previously valid on: 2016-08-09 18:20:56 UTC, previous status: [Valid]

[----] I, [2016-08-09T16:21:13.081870 #25371:11a5990]  INFO -- : MIQ(MiqQueue.put) Message id: [5854],  id: [], Zone: [default], Role: [], Server: [], Ident: [generic], Target id: [], Instance id: [], Task id: [], Command: [MiqEvent.raise_evm_event], Timeout: [600], Priority: [100], State: [ready], Deliver On: [], Data: [], Args: 
[["ManageIQ::Providers::Redhat::InfraManager", 1], "ems_auth_invalid", {}]

[----] I, [2016-08-09T16:21:13.802624 #25371:11a5990]  INFO -- : MIQ(ManageIQ::Providers::Redhat::InfraManager::RefreshWorker#log_status) [Refresh Worker for Cloud/Infrastructure Providers: nested-rhevm35] Worker ID [50], PID [25371], GUID [d0b947d8-5e6e-11e6-8841-fa163e04f471], Last Heartbeat [2016-08-09 20:21:12 UTC], Process Info: Memory Usage [265449472], Memory Size [651583488], Proportional Set Size: [161991000], Memory % [3.24], CPU Time [31.0], CPU % [0.0], Priority [27]

[----] E, [2016-08-09T16:21:13.803225 #25371:11a5990] ERROR -- : EMS [10.16.4.139] as [admin@internal] ID [50] PID [25371] GUID [d0b947d8-5e6e-11e6-8841-fa163e04f471] EMS id [1] failed authentication check. Worker exiting.

[----] I, [2016-08-09T16:21:14.196361 #2804:11a5990]  INFO -- : MIQ(MiqServer#clean_worker_records) SQL Record for Worker [ManageIQ::Providers::Redhat::InfraManager::RefreshWorker] with ID: [31], PID: [18303], GUID: [0305e4d2-5e5e-11e6-8841-fa163e04f471], Status: [stopped] is being deleted

[----] I, [2016-08-09T16:21:14.217424 #2804:11a5990]  INFO -- : MIQ(MiqServer#clean_worker_records) SQL Record for Worker [ManageIQ::Providers::Redhat::InfraManager::RefreshWorker] with ID: [50], PID: [25371], GUID: [d0b947d8-5e6e-11e6-8841-fa163e04f471], Status: [aborted] is being deleted

Version-Release number of selected component (if applicable):
------------------------------------------------------------
5.6.1


How reproducible:
----------------
Always


Steps to Reproduce:
-------------------
1.Manage a RHEVM provider
2.Add and validate C&U credentials


Actual results:
--------------
1.C&U data is fetched from the provider for a while.
2.At some point, the default credentials become invalid.


Expected results:
-----------------


Additional info:
----------------

Comment 3 Nandini Chandra 2016-08-11 19:53:44 UTC
Marked this as urgent since provider refresh fails and as a result, C&U data collection fails and hence this is blocking C&U testing of RHEVM providers.

Comment 4 Greg Blomquist 2016-08-12 19:08:24 UTC
> [----] E, [2016-08-09T16:21:12.940663 #25371:11a5990] ERROR -- : <RHEVM> Ovirt::Service#resource_get: class = Errno::EHOSTUNREACH, message=No route to host - connect(2) for "10.zz.xx.yy" port 5000, URI=https://10.zz.xx.yy:5000/api

Dan, 

I believe that this is because the angular form is setting a default port value to 5000 for the RHEV provider credentials.  Can you have someone on the UI team validate that the angular form is not setting a default port value for RHEV providers to 5000? 

If it looks like there's nothing being set in the angular form, reassign back to providers to dig into.

Comment 7 lgalis 2016-08-19 16:33:34 UTC

*** This bug has been marked as a duplicate of bug 1361258 ***


Note You need to log in before you can comment on or make changes to this bug.