Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365931 - [RFE] Tag Visibility - Network module should honor tag visibility
Summary: [RFE] Tag Visibility - Network module should honor tag visibility
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: John Hardy
QA Contact: Ramesh A
URL:
Whiteboard: network:tag
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 14:24 UTC by Ramesh A
Modified: 2017-08-28 15:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-28 15:03:24 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ramesh A 2016-08-10 14:24:00 UTC
Description of problem:
Network module should honor tag visibility

Version-Release number of selected component (if applicable):
5.6.1.0.20160726144018_810a94f 

How reproducible:
Very

Steps to Reproduce:
1. Create a new role
2. Create a new group based out of the above role.  Assign a tag in "My Company Tags" under "Assign Filters" section 
2. Create a user and assign the above role
3. As admin, navigate to Network ==> choose any sub module which has policy option (except Topology, policy option is not available there) say, Providers, Networks, Subnets, Network Router, Security Groups, Floating IP or Network Ports
4. Choose any one scenario:
  a) Do not assign any tags to any item
  b) Select any one item displayed under the above selected sub module, from Policy ==> Edit Tags ==> Assign the tag which is used in Step-2
5. Login as newly created user and Navigate to the respective sub-module and check the items displayed

Actual results:
Displays all the items despite the access restriction as applied in Step-4

Expected results:
Should honor tag visibility and display the corresponding items associated with filtered permission

Additional info:

Comment 3 Chris Pelland 2017-08-28 15:03:24 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.