Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365919 - WebUI: Tag Visibility - Clicking on "Download as Text" for Tenant throws "negative argument [cloud_tenant/download_data]" error
Summary: WebUI: Tag Visibility - Clicking on "Download as Text" for Tenant throws "neg...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Brian McLaughlin
QA Contact: Dave Johnson
URL:
Whiteboard: cloud:tenant:report:tag
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 13:52 UTC by Ramesh A
Modified: 2017-08-21 13:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-21 13:07:18 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)
error (deleted)
2016-08-10 13:52 UTC, Ramesh A
no flags Details

Description Ramesh A 2016-08-10 13:52:34 UTC
Created attachment 1189633 [details]
error

Description of problem:
Clicking on "Download as Text" for Tenant throws "negative argument [cloud_tenant/download_data]" error

Version-Release number of selected component (if applicable):
5.6.1.0.20160726144018_810a94f 

How reproducible:
Very

Steps to Reproduce:
1. Create a new role
2. Create a new group based out of the above role.  Assign a tag in "My Company Tags" under "Assign Filters" section 
2. Create a user and assign the above role
3. As admin, navigate to Compute ==> Clouds ==> Tenants ==> Select any Tenant ==> Policy ==> Edit Tags ==> Assign the above used tag
4. Login as the newly created user, navigate to Compute ==> Clouds ==> Tenants
5. Click on the Download button, choose "Download as Text" option

Actual results:
Throws "negative argument [cloud_tenant/download_data]" error. Refer the screenshot and production.log file for further information

Expected results:
Should be able to download the report in text file

Additional info:
production.log:
==============
[----] I, [2016-08-10T09:45:22.009198 #3102:11d9f38]  INFO -- : Started GET "/cloud_tenant/download_data?download_type=text" for 127.0.0.1 at 2016-08-10 09:45:22 -0400
[----] I, [2016-08-10T09:45:22.011212 #3102:11d9f38]  INFO -- : Processing by CloudTenantController#download_data as HTML
[----] I, [2016-08-10T09:45:22.011340 #3102:11d9f38]  INFO -- :   Parameters: {"download_type"=>"text"}
[----] F, [2016-08-10T09:45:22.098811 #3102:11d9f38] FATAL -- : Error caught: [ArgumentError] negative argument
/var/www/miq/vmdb/lib/report_formatter/text.rb:176:in `*'
/var/www/miq/vmdb/lib/report_formatter/text.rb:176:in `build_document_footer'
/opt/rh/cfme-gemset/bundler/gems/ruport-3727775479b0/lib/ruport/controller.rb:598:in `maybe'
/opt/rh/cfme-gemset/bundler/gems/ruport-3727775479b0/lib/ruport/controller.rb:584:in `block in execute_stages'
/opt/rh/cfme-gemset/bundler/gems/ruport-3727775479b0/lib/ruport/controller.rb:583:in `each'
/opt/rh/cfme-gemset/bundler/gems/ruport-3727775479b0/lib/ruport/controller.rb:583:in `execute_stages'
/opt/rh/cfme-gemset/bundler/gems/ruport-3727775479b0/lib/ruport/controller.rb:574:in `_run_'
/opt/rh/cfme-gemset/bundler/gems/ruport-3727775479b0/lib/ruport/controller.rb:520:in `run'
/opt/rh/cfme-gemset/bundler/gems/ruport-3727775479b0/lib/ruport/controller.rb:436:in `render'
/var/www/miq/vmdb/app/models/miq_report/formatters/text.rb:3:in `to_text'
/var/www/miq/vmdb/app/controllers/application_controller/report_downloads.rb:125:in `download_txt'
/var/www/miq/vmdb/app/controllers/application_controller/report_downloads.rb:113:in `download_data'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_controller/metal/basic_implicit_render.rb:4:in `send_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/abstract_controller/base.rb:188:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_controller/metal/rendering.rb:30:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/abstract_controller/callbacks.rb:20:in `block in process_action'
/opt/rh/cfme-gemset/gems/activesupport-5.0.0/lib/active_support/callbacks.rb:126:in `call'
/opt/rh/cfme-gemset/gems/activesupport-5.0.0/lib/active_support/callbacks.rb:126:in `call'
/opt/rh/cfme-gemset/gems/activesupport-5.0.0/lib/active_support/callbacks.rb:506:in `block (2 levels) in compile'
/opt/rh/cfme-gemset/gems/activesupport-5.0.0/lib/active_support/callbacks.rb:455:in `call'
/opt/rh/cfme-gemset/gems/activesupport-5.0.0/lib/active_support/callbacks.rb:455:in `call'
/opt/rh/cfme-gemset/gems/activesupport-5.0.0/lib/active_support/callbacks.rb:101:in `__run_callbacks__'
/opt/rh/cfme-gemset/gems/activesupport-5.0.0/lib/active_support/callbacks.rb:750:in `_run_process_action_callbacks'
/opt/rh/cfme-gemset/gems/activesupport-5.0.0/lib/active_support/callbacks.rb:90:in `run_callbacks'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/abstract_controller/callbacks.rb:19:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_controller/metal/rescue.rb:20:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_controller/metal/instrumentation.rb:32:in `block in process_action'
/opt/rh/cfme-gemset/gems/activesupport-5.0.0/lib/active_support/notifications.rb:164:in `block in instrument'
/opt/rh/cfme-gemset/gems/activesupport-5.0.0/lib/active_support/notifications/instrumenter.rb:21:in `instrument'
/opt/rh/cfme-gemset/gems/activesupport-5.0.0/lib/active_support/notifications.rb:164:in `instrument'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_controller/metal/instrumentation.rb:30:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_controller/metal/params_wrapper.rb:248:in `process_action'
/opt/rh/cfme-gemset/gems/activerecord-5.0.0/lib/active_record/railties/controller_runtime.rb:18:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/abstract_controller/base.rb:126:in `process'
/opt/rh/cfme-gemset/gems/actionview-5.0.0/lib/action_view/rendering.rb:30:in `process'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_controller/metal.rb:190:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_controller/metal.rb:262:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_dispatch/routing/route_set.rb:50:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_dispatch/routing/route_set.rb:32:in `serve'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_dispatch/journey/router.rb:39:in `block in serve'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_dispatch/journey/router.rb:26:in `each'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_dispatch/journey/router.rb:26:in `serve'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_dispatch/routing/route_set.rb:725:in `call'
/opt/rh/cfme-gemset/gems/secure_headers-3.0.3/lib/secure_headers/middleware.rb:10:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.1/lib/rack/etag.rb:25:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.1/lib/rack/conditional_get.rb:25:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.1/lib/rack/head.rb:12:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.1/lib/rack/session/abstract/id.rb:222:in `context'
/opt/rh/cfme-gemset/gems/rack-2.0.1/lib/rack/session/abstract/id.rb:216:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_dispatch/middleware/cookies.rb:613:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_dispatch/middleware/callbacks.rb:38:in `block in call'
/opt/rh/cfme-gemset/gems/activesupport-5.0.0/lib/active_support/callbacks.rb:97:in `__run_callbacks__'
/opt/rh/cfme-gemset/gems/activesupport-5.0.0/lib/active_support/callbacks.rb:750:in `_run_call_callbacks'
/opt/rh/cfme-gemset/gems/activesupport-5.0.0/lib/active_support/callbacks.rb:90:in `run_callbacks'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_dispatch/middleware/callbacks.rb:36:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_dispatch/middleware/remote_ip.rb:79:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_dispatch/middleware/debug_exceptions.rb:49:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_dispatch/middleware/show_exceptions.rb:31:in `call'
/opt/rh/cfme-gemset/gems/railties-5.0.0/lib/rails/rack/logger.rb:36:in `call_app'
/opt/rh/cfme-gemset/gems/railties-5.0.0/lib/rails/rack/logger.rb:26:in `call'
/opt/rh/cfme-gemset/gems/request_store-1.3.1/lib/request_store/middleware.rb:9:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_dispatch/middleware/request_id.rb:24:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.1/lib/rack/method_override.rb:22:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.1/lib/rack/runtime.rb:22:in `call'
/opt/rh/cfme-gemset/gems/activesupport-5.0.0/lib/active_support/cache/strategy/local_cache_middleware.rb:28:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.0/lib/action_dispatch/middleware/executor.rb:12:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.1/lib/rack/sendfile.rb:111:in `call'
/opt/rh/cfme-gemset/gems/railties-5.0.0/lib/rails/engine.rb:522:in `call'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/puma-3.3.0/lib/puma/configuration.rb:224:in `call'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/puma-3.3.0/lib/puma/server.rb:561:in `handle_request'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/puma-3.3.0/lib/puma/server.rb:406:in `process_client'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/puma-3.3.0/lib/puma/server.rb:271:in `block in run'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/puma-3.3.0/lib/puma/thread_pool.rb:111:in `call'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/puma-3.3.0/lib/puma/thread_pool.rb:111:in `block in spawn_thread'
/opt/rh/cfme-gemset/gems/logging-2.1.0/lib/logging/diagnostic_context.rb:450:in `call'
/opt/rh/cfme-gemset/gems/logging-2.1.0/lib/logging/diagnostic_context.rb:450:in `block in create_with_logging_context'
[----] I, [2016-08-10T09:45:22.100515 #3102:11d9f38]  INFO -- :   Rendering layouts/exception.html.haml within layouts/application
[----] I, [2016-08-10T09:45:22.101183 #3102:11d9f38]  INFO -- :   Rendered layouts/_exception_contents.html.haml (0.2ms)
[----] I, [2016-08-10T09:45:22.101378 #3102:11d9f38]  INFO -- :   Rendered layouts/exception.html.haml within layouts/application (0.6ms)
[----] I, [2016-08-10T09:45:22.101769 #3102:11d9f38]  INFO -- :   Rendered layouts/_doctype.html.haml (0.1ms)
[----] I, [2016-08-10T09:45:22.103272 #3102:11d9f38]  INFO -- :   Rendered stylesheets/_template50.html.haml (0.1ms)
[----] I, [2016-08-10T09:45:22.105575 #3102:11d9f38]  INFO -- :   Rendered layouts/_i18n_js.html.haml (1.4ms)
[----] I, [2016-08-10T09:45:22.119230 #3102:11d9f38]  INFO -- :   Rendered layouts/_user_options.html.haml (3.9ms)
[----] I, [2016-08-10T09:45:22.119629 #3102:11d9f38]  INFO -- :   Rendered layouts/_spinner.html.haml (0.1ms)
[----] I, [2016-08-10T09:45:22.120003 #3102:11d9f38]  INFO -- :   Rendered layouts/_lightbox_panel.html.haml (0.1ms)
[----] I, [2016-08-10T09:45:22.120146 #3102:11d9f38]  INFO -- :   Rendered layouts/_header.html.haml (14.1ms)
[----] I, [2016-08-10T09:45:22.143055 #3102:11d9f38]  INFO -- :   Rendered layouts/_vertical_navbar.html.haml (22.5ms)
[----] I, [2016-08-10T09:45:22.143453 #3102:11d9f38]  INFO -- :   Rendered layouts/_breadcrumbs.html.haml (0.1ms)
[----] I, [2016-08-10T09:45:22.143885 #3102:11d9f38]  INFO -- :   Rendered layouts/_content.html.haml (23.5ms)
[----] I, [2016-08-10T09:45:22.144397 #3102:11d9f38]  INFO -- :   Rendered layouts/_adv_search.html.haml (0.1ms)
[----] I, [2016-08-10T09:45:22.144549 #3102:11d9f38]  INFO -- :   Rendered layouts/_footer.html.haml (0.4ms)
[----] I, [2016-08-10T09:45:22.145060 #3102:11d9f38]  INFO -- : Completed 500 Internal Server Error in 134ms (Views: 45.4ms | ActiveRecord: 0.0ms)
[----] I, [2016-08-10T09:45:24.196191 #3102:11ce674]  INFO -- : Started POST "/dashboard/window_sizes?width=1366&height=601" for 127.0.0.1 at 2016-08-10 09:45:24 -0400
[----] I, [2016-08-10T09:45:24.198168 #3102:11ce674]  INFO -- : Processing by DashboardController#window_sizes as JS
[----] I, [2016-08-10T09:45:24.198285 #3102:11ce674]  INFO -- :   Parameters: {"width"=>"1366", "height"=>"601"}
[----] I, [2016-08-10T09:45:24.202042 #3102:11ce674]  INFO -- : Completed 200 OK in 4ms (ActiveRecord: 0.0ms)

Comment 2 Harpreet Kataria 2016-08-10 19:44:36 UTC
Brian,

I was not able to recreate this on upstream, can you see if you can recreate or track down the code and see if this has already been fixed. Let me know what you find.

Thanks,
~Harpreet

Comment 3 Chris Pelland 2017-08-21 13:07:18 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Comment 4 Chris Pelland 2017-08-21 13:09:36 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.