Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365911 - result notchecked is reported on the terminal in white color
Summary: result notchecked is reported on the terminal in white color
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openscap
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Martin Preisler
QA Contact: Watson Yuuma Sato
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 13:24 UTC by Marek Haicman
Modified: 2017-08-01 08:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 08:45:48 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2291 normal SHIPPED_LIVE openscap bug fix update 2017-08-01 12:38:59 UTC

Description Marek Haicman 2016-08-10 13:24:57 UTC
Description of problem:
When xccdf rule is not evaluated and notchecked result is reported, it is reported as bold white text. This is less than optimal in case terminal is configured to have white background.

Version-Release number of selected component (if applicable):
openscap-1.2.10-1.el7

How reproducible:
reliably

Steps to Reproduce:
1. run xccdf rule with notchecked result

Actual results:
bold white text even in case terminal is configured to black text on white background [thus result looks like an empty space]

Expected results:
default text color, boldened?

Additional info:

Comment 3 Martin Preisler 2017-01-11 21:28:37 UTC
Upstream fix proposed: https://github.com/OpenSCAP/openscap/pull/647

Comment 8 errata-xmlrpc 2017-08-01 08:45:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2291


Note You need to log in before you can comment on or make changes to this bug.