Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365870 - Systemd-tmpfiles does not set owner/group defined by z-directive
Summary: Systemd-tmpfiles does not set owner/group defined by z-directive
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: Branislav Blaškovič
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 11:35 UTC by Jakub Martisko
Modified: 2016-11-04 00:56 UTC (History)
2 users (show)

Fixed In Version: systemd-219-27.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 00:56:02 UTC


Attachments (Terms of Use)
reproducer (deleted)
2016-08-10 11:35 UTC, Jakub Martisko
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2216 normal SHIPPED_LIVE systemd bug fix and enhancement update 2016-11-03 13:24:51 UTC

Description Jakub Martisko 2016-08-10 11:35:44 UTC
Created attachment 1189585 [details]
reproducer

Directives in the tmpfiles config files seem to be executed in a wrong order -> when creating a new file and setting an owner and group of that file using "f" and "z" directives, respectively, the order of execution of those directives is not guaranteed - changes made by "z" directive might be overwritten by "f" directive.

How to reproduce:
Run the attached reproducer.

Expected result:
-rwxrwxrwt. 1 root root 0 10. srp 07.03 hello.test

Actual result:
-rwxrwxrwt. 1 root bar   0 10. srp 06.57 hello.test

Notes:
This seems to be fixed by an upstream patch [1]. According to the commit message, the order of execution of the directives without the patch is not deterministic -> the reproducer might thus sometimes return expected results.

[1]: https://github.com/systemd/systemd/commit/17493fa5d17cadce3b773692d3eeab137de7d323?diff=unified.patch

Comment 1 Branislav Blaškovič 2016-08-10 13:15:02 UTC
qa acking

Comment 6 errata-xmlrpc 2016-11-04 00:56:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2216.html


Note You need to log in before you can comment on or make changes to this bug.