Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365864 - gfapi: use const qualifier for glfs_*timens()
Summary: gfapi: use const qualifier for glfs_*timens()
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: 3.8.2
Hardware: All
OS: All
unspecified
low
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 11:31 UTC by Oleksandr Natalenko
Modified: 2016-08-24 10:20 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-24 10:20:46 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Oleksandr Natalenko 2016-08-10 11:31:17 UTC
Backport https://bugzilla.redhat.com/show_bug.cgi?id=1365506 fix to 3.8.

Comment 1 Vijay Bellur 2016-08-10 11:31:49 UTC
REVIEW: http://review.gluster.org/15136 (gfapi: use const qualifier for glfs_*timens()) posted (#1) for review on release-3.8 by Oleksandr Natalenko (oleksandr@natalenko.name)

Comment 2 Vijay Bellur 2016-08-12 11:19:45 UTC
COMMIT: http://review.gluster.org/15136 committed in release-3.8 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 4824f19e66d4fad4d41082fda398867aae5ef8a6
Author: Oleksandr Natalenko <oleksandr@natalenko.name>
Date:   Tue Aug 9 14:58:08 2016 +0300

    gfapi: use const qualifier for glfs_*timens()
    
    glfs_*timens() functions have the last argument
    of struct timespec type that is supposed to be
    const. Now using glfs_*timens() in fops, implemented
    on top of FUSE library, leads to compiler-time warning
    about discarding const qualifier.
    
    Introducing const qualifier does not break ABI,
    so let's just fix it.
    
    > Reviewed-on: http://review.gluster.org/15119
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Niels de Vos <ndevos@redhat.com>
    
    BUG: 1365864
    Change-Id: Iea2a1018de7dce67f67a8229671a5978246de800
    Signed-off-by: Oleksandr Natalenko <oleksandr@natalenko.name>
    Reviewed-on: http://review.gluster.org/15136
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>

Comment 3 Niels de Vos 2016-08-24 10:20:46 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.3, please open a new bug report.

glusterfs-3.8.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/announce/2016-August/000059.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.