Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365859 - scap-workbench rpm does not ship with LICENSE file
Summary: scap-workbench rpm does not ship with LICENSE file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: scap-workbench
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Martin Preisler
QA Contact: Marek Haicman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 11:20 UTC by Marek Haicman
Modified: 2017-08-01 09:09 UTC (History)
3 users (show)

Fixed In Version: scap-workbench-1.1.4-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:09:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2296 normal SHIPPED_LIVE scap-workbench bug fix update 2017-08-01 12:40:10 UTC

Description Marek Haicman 2016-08-10 11:20:49 UTC
Description of problem:
Every package should install COPYING, COPYRIGHT or LICENSE file in /usr/share/doc/PACKAGE_NAME-VERSION directory. scap-workbench has correct LICENSE file in SRPM, but not in RPM.

Version-Release number of selected component (if applicable):
scap-workbench-1.1.2-1.el7

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
no LICENSE file present

Expected results:
LICENSE file containing GPLv3 license installed in /usr/share/doc/scap-workbench-VERSION directory

Additional info:
Even the "About" dialog of scap-workbench mentions "You should have received a copy of the GNU General Public License along with this program."

Comment 5 Marek Haicman 2017-04-26 09:16:52 UTC
In latest version, COPYING is installed as part of package

[0 root@qeos-22 ~]# rpm -q scap-workbench
scap-workbench-1.1.4-4.el7.x86_64
[0 root@qeos-22 ~]# rpm -ql scap-workbench | grep doc
/usr/share/doc/scap-workbench-1.1.4/COPYING
/usr/share/doc/scap-workbench-1.1.4/README.md
/usr/share/doc/scap-workbench-1.1.4/user_manual.html

[0 root@qeos-22 ~]# head -2 /usr/share/doc/scap-workbench-1.1.4/COPYING
                    GNU GENERAL PUBLIC LICENSE
                       Version 3, 29 June 2007

Comment 6 errata-xmlrpc 2017-08-01 09:09:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2296


Note You need to log in before you can comment on or make changes to this bug.