Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365850 - [Doc RFE] Document arbiter volume type
Summary: [Doc RFE] Document arbiter volume type
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: doc-Administration_Guide
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: RHGS 3.2.0
Assignee: Laura Bailey
QA Contact: SATHEESARAN
URL:
Whiteboard:
: 1361117 (view as bug list)
Depends On:
Blocks: 1351549
TreeView+ depends on / blocked
 
Reported: 2016-08-10 10:57 UTC by Anjana Suparna Sriram
Modified: 2017-03-24 01:10 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-24 01:10:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1361101 None None None Never

Internal Links: 1361101

Description Anjana Suparna Sriram 2016-08-10 10:57:37 UTC
Document URL: https://access.redhat.com/documentation/en-US/Red_Hat_Storage/3.1/html/Administration_Guide/index.html


Additional information: POC - Ravi

Comment 15 Alok 2016-10-17 02:31:03 UTC
We need to give a simple sizing recommendation to the customer. The recommendation in comment 12 about killing the data brick, running workload, etc will be an overhead for the administrator. Also, from the description, This sizing recommendation may not be accurate as the rate of space consumption will not be constant.

Comment 16 Laura Bailey 2016-10-18 23:53:55 UTC
*** Bug 1361117 has been marked as a duplicate of this bug. ***

Comment 36 Manoj Pillai 2016-11-21 10:24:27 UTC
Much of the content in the tuning recommendations section is not specific to Arbiter volumes. Can we put recommendations specific to Arbiter volumes in this section and point to existing sections for general recommendations?

Comment 37 Manoj Pillai 2016-11-21 10:27:20 UTC
Shekhar, can you help Laura rewrite the tuning recommendations as requested in comment #36?

Comment 38 Shekhar Berry 2016-11-21 14:15:24 UTC
Laura, As per Manoj's suggestion we can point to  https://access.redhat.com/documentation/en-US/Red_Hat_Storage/3.1/html/Administration_Guide/chap-Configuring_Red_Hat_Storage_for_Enhancing_Performance.html for general recommendation.

In respect to Arbiter volume, only 1st two points under tuning heading holds true i.e.
 For dedicated arbiter nodes, use JBOD for arbiter bricks, and RAID-6 for data bricks.
For chained arbiter volumes, use the same RAID-6 drive for both data and arbiter bricks. 

The rest all can be covered under general recommendation.

Best Regards
Shekhar

Comment 44 SATHEESARAN 2017-02-01 09:37:48 UTC
I have following comments

0. It will be good to output the volume configuration for arbitrated replicate volume as captured from gluster volume info output

The section 6.8.3 should have the following post volume creation example:
Volume Name: testvol
Type: Replicate
Volume ID: ed9fa4d5-37f1-49bb-83c3-925e90fab1bc
Status: Created
Snapshot Count: 0
Number of Bricks: 2 x (2 + 1) = 3
Transport-type: tcp
Bricks:
Brick1: server1:/bricks/brick
Brick2: server2:/bricks/brick
Brick3: server3:/bricks/brick (arbiter)
Brick1: server4:/bricks/brick
Brick2: server5:/bricks/brick
Brick3: server6:/bricks/brick (arbiter)
Options Reconfigured:
transport.address-family: inet
performance.readdir-ahead: on
nfs.disable: on

1. Just above the figure 6.7, I see that the configuration is mentioned as 6*(2+1)
Please make it changed to 6 x (2+1)

2. "Converting to an arbitrated volume" should be renamed as "Converting to an arbitrated replicate volume"

3. The second example under "Converting to an arbitrated replicate volume" can provide the volume configuration mathematically.

Say, for example - The current content goes like this :
"If you have an existing two-way distributed-replicated volume, you need a new brick for each sub-volume in order to convert it to an arbitrated distributed-replicated volume"

It would be more easy to understand when the statement goes like - 
"If you have an existing two-way distributed-replicated volume (2 x 2), you need a new brick for each sub-volume in order to convert it to an arbitrated distributed-replicated volume (2 x (2+1))"

To make the above said modifications, I'm moving this bug to ASSIGNED

Comment 46 SATHEESARAN 2017-02-07 10:23:05 UTC
Laura,

In the section 6.8.3, following the volume creation command, could you please add the following: "# gluster volume info testvol" followed by volume information.

I have missed to provide the command in comment44

Comment 48 SATHEESARAN 2017-02-08 17:55:23 UTC
(In reply to Laura Bailey from comment #47)
> Added after the example command, assume this is the one you meant.
> 
> Fixed section is here:
> 
> http://ccs-jenkins.gsslab.brq.redhat.com:8080/view/Topic%20branches%20-
> %20Gluster/job/doc-Red_Hat_Gluster_Storage-3.2-Administration_Guide-branch-
> master/lastSuccessfulBuild/artifact/tmp/en-US/html-single/index.
> html#Creating_Arbitrated_Replicated_Volumes

Yes, you got me right.

verified with the changes cited in the doc_link in comment47

Comment 49 Laura Bailey 2017-03-24 01:10:02 UTC
Moving to CLOSED CURRENTRELEASE since RHGS 3.2 GA was yesterday. All documentation is available from https://access.redhat.com/documentation/en/red-hat-gluster-storage/.


Note You need to log in before you can comment on or make changes to this bug.