Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365831 - virt-v2v add <graphics type='sdl'/> to guest while do conversion with '-i disk'
Summary: virt-v2v add <graphics type='sdl'/> to guest while do conversion with '-i disk'
Keywords:
Status: CLOSED DUPLICATE of bug 1372671
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.3
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard: V2V
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 10:15 UTC by zhoujunqin
Modified: 2016-09-20 10:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-20 10:52:57 UTC


Attachments (Terms of Use)
6test1-debug.log with '-v -x' (deleted)
2016-08-10 10:15 UTC, zhoujunqin
no flags Details

Description zhoujunqin 2016-08-10 10:15:29 UTC
Created attachment 1189547 [details]
6test1-debug.log with '-v -x'

Description of problem:
virt-v2v add <graphics type='sdl'/> to guest while do conversion with '-i disk', due to guest boot up failed.

Version-Release number of selected component (if applicable):
libvirt-2.0.0-4.el7.x86_64
libguestfs-1.32.7-1.el7.x86_64
virt-v2v-1.32.7-1.el7.x86_64
qemu-kvm-rhev-2.6.0-19.el7.x86_64


How reproducible:
100%

Steps to Reproduce:

1.Convert guest from disk image with option '-i disk'.

# virt-v2v -i disk 6test1.img -os opt
[   0.0] Opening the source -i disk 6test1.img
[   0.3] Creating an overlay to protect the source from being modified
[   0.4] Initializing the target -o libvirt -os opt
[   0.4] Opening the overlay
[   5.7] Inspecting the overlay
[  16.0] Checking for sufficient free disk space in the guest
[  16.0] Estimating space required on target for each disk
[  16.0] Converting Red Hat Enterprise Linux Server release 6.8 (Santiago) to run on KVM
virt-v2v: warning: /files/boot/grub/device.map/hd0 references unknown 
device "vda".  You may have to fix this entry manually after conversion.
virt-v2v: warning: /files/etc/sysconfig/grub/boot references unknown device 
"vda".  You may have to fix this entry manually after conversion.
virt-v2v: This guest has virtio drivers installed.
[  65.4] Mapping filesystem data to avoid copying unused and blank areas
[  65.5] Closing the overlay
[  65.5] Checking if the guest needs BIOS or UEFI to boot
[  65.5] Assigning disks to buses
[  65.5] Copying disk 1/1 to /opt/6test1-sda (raw)
    (100.00/100%)
[ 133.7] Creating output metadata
Pool opt refreshed

Domain 6test1 defined from /tmp/v2vlibvirt387543.xml

2.After conversion, boot up guest '6test1'

Actual results:
1. After step2, failed to boot up guest.
# virsh start 6test1
error: Failed to start domain 6test1
error: internal error: process exited while connecting to monitor: qemu-kvm: -sdl: SDL support is disabled

2. Check guest's xml find  <graphics type='sdl'/> is added.


Expected results:
While do conversion, should not add sdl graphics to guest.

Additional info:

Comment 2 Pino Toscano 2016-09-20 10:52:57 UTC
This is basically what is reported as bug 1372671 -- marking this as duplicate, even if reported before, as bug 1372671 has more discussion.

*** This bug has been marked as a duplicate of bug 1372671 ***


Note You need to log in before you can comment on or make changes to this bug.