Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365828 - Regression: 4.6.5-300.fc24 breaks hda_intel sound on Lenovo Thinkpad P50
Summary: Regression: 4.6.5-300.fc24 breaks hda_intel sound on Lenovo Thinkpad P50
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 24
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 10:03 UTC by Matthias Hensler
Modified: 2016-09-06 15:21 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-06 15:21:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Linux Kernel 151811 None None None 2016-08-10 10:03:18 UTC

Description Matthias Hensler 2016-08-10 10:03:18 UTC
Description of problem:
After updating from 4.6.4-301.fc24 to current 4.6.5-300.fc24 the sound is gone.


Version-Release number of selected component (if applicable):
4.6.5-300.fc24


Actual results:
Booting with 4.6.5-300.fc24 yields in the following message:
  HSW/BDW HD-audio HDMI/DP requires binding with gfx driver

Sound is not working then.

Expected results:
Sound should be working :-)


Additional info:
I already filed a bug upstream, as I figured it was related to a handful of changes to the hda-driver between 4.6.4 and 4.6.5. However after some discussion it turned out, that the problem is actually resulting from a patch only included in the Fedora kernelbuild of 4.6.5-300.fc24.

For details and some dmesg/alsa-info differences see Kernel-BZ 151811 (https://bugzilla.kernel.org/show_bug.cgi?id=151811).

The patch in question is number 838 (Revert-ALSA-hda-remove-controller-dependency-on-i915.patch).

I rebuild 4.6.5-300.fc24 only with patch 838 disabled and can confirm that sound is now working as before.

It looks like the patch in question is some backport with quite some history. In any case it seems harmful to my system as it breaks sound completely and therefore needs some more work :)

Comment 1 Laura Abbott 2016-08-10 12:57:10 UTC
Thanks for the report. The patch in question was dropped recently http://pkgs.fedoraproject.org/cgit/rpms/kernel.git/commit/?h=f24&id=80b44af41af09604f181ac7d4eeebbf476bfe05a but it hasn't made it to a build yet. 4.6.6 is due to come out today so an official build should be available sometime in the next few days

Comment 2 Garrett Mitchener 2016-08-10 13:30:41 UTC
Glad to see that a fix is already in the works.  Meanwhile, using kernel 4.6.4 works.

For what it's worth: I'm also seeing this on a Dell Precision 3620

from LSPCI:

00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]

Comment 3 Laura Abbott 2016-08-11 14:02:52 UTC
Please test https://bodhi.fedoraproject.org/updates/FEDORA-2016-90f142aa64, this build dropped the patch

Comment 4 Matthias Hensler 2016-08-12 10:08:21 UTC
Above build fixes the issue for me, already gave my karma on bodhi.

Comment 5 info@kobaltwit.be 2016-08-16 10:39:01 UTC
Was this patch also dropped from 4.6.6-200 on Fedora 23 ?

I installed that version today and sound is still not working there. Reverting back to 4.6.4 on my system does restor working sound.

Symptoms are the same - same error message in journal, no sound.

Comment 6 Herwig Wiesinger 2016-08-17 06:05:26 UTC
Same Problem. 
Fedora 23. 
Additional Nvidia Graphics Card (not using the internal).

kernel 4.6.4-200 works
kernel 4.6.5-200 no audio
kernel 4.6.6-200 no audio

Motherboard ASUS B150M-C

Comment 7 info@kobaltwit.be 2016-09-03 08:28:02 UTC
For the record - this was fixed for me with kernel 4.6.7-200.fc23.x86_64.


Note You need to log in before you can comment on or make changes to this bug.