Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365756 - [SSL] : gluster v set help does not show ssl options
Summary: [SSL] : gluster v set help does not show ssl options
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.8.2
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Mohit Agrawal
QA Contact:
URL:
Whiteboard:
Depends On: 1338615 1351134 1365757
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 07:25 UTC by Mohit Agrawal
Modified: 2016-08-24 10:20 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1351134
Environment:
Last Closed: 2016-08-24 10:20:46 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohit Agrawal 2016-08-10 07:25:27 UTC
+++ This bug was initially created as a clone of Bug #1351134 +++

+++ This bug was initially created as a clone of Bug #1338615 +++

Description of problem:
-----------------------

gluster v set help does not show "help" for ssl related configurables :

[root@gqas011 /]# gluster v set help|grep server.ssl
[root@gqas011 /]# 
[root@gqas011 /]# gluster v set help|grep client.ssl
[root@gqas011 /]# 


Version-Release number of selected component (if applicable):
-------------------------------------------------------------

3.7.9-5

How reproducible:
----------------

100%

Steps to Reproduce:
------------------

Type : gluster v set help|grep server.ssl/gluster v set help|grep client.ssl on one of the nodes.

Actual results:
--------------

No help reg these options is shown.

Expected results:
----------------

The option,description and the default value should be shown.

Additional info:
---------------

-

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-05-23 02:53:45 EDT ---

This bug is automatically being proposed for the current z-stream release of Red Hat Gluster Storage 3 by setting the release flag 'rhgs‑3.1.z' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.

--- Additional comment from Atin Mukherjee on 2016-05-23 04:19:13 EDT ---

This is because the options are configured as NO_DOC in glusterd's volume map entry table. I'd need to check with the author of these options about why this was introduced like it.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-06-29 06:25:24 EDT ---

This bug is automatically being proposed for the current z-stream release of Red Hat Gluster Storage 3 by setting the release flag 'rhgs‑3.1.z' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.

--- Additional comment from Vijay Bellur on 2016-06-29 06:28:11 EDT ---

REVIEW: http://review.gluster.org/14829 (gluster v set help does not show ssl options) posted (#2) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

--- Additional comment from Vijay Bellur on 2016-07-08 01:55:22 EDT ---

REVIEW: http://review.gluster.org/14829 (gluster v set help does not show ssl options) posted (#3) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)

--- Additional comment from Vijay Bellur on 2016-07-12 05:30:15 EDT ---

COMMIT: http://review.gluster.org/14829 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 9733c68e878869daec196bf7bca16780eef73f74
Author: Mohit Agrawal <moagrawa@redhat.com>
Date:   Wed Jun 29 15:36:41 2016 +0530

    gluster v set help does not show ssl options
    
    Problem: "gluster v set help" does not show ssl options.
    
    Solution: Remove NO_DOC option for client.ssl/server.ssl from glusterd_volopt_map.
    
    Change-Id: Iabe982ea56398209bbf30d41260798e5ad7fce7b
    BUG: 1351134
    Signed-off-by: Mohit Agrawal <moagrawa@redhat.com>
    Reviewed-on: http://review.gluster.org/14829
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 1 Vijay Bellur 2016-08-10 07:28:59 UTC
REVIEW: http://review.gluster.org/15130 (gluster v set help does not show ssl options) posted (#1) for review on release-3.8 by MOHIT AGRAWAL (moagrawa@redhat.com)

Comment 2 Vijay Bellur 2016-08-11 03:58:28 UTC
COMMIT: http://review.gluster.org/15130 committed in release-3.8 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 9fec821d74204fc202a09da6044745b8ca584696
Author: Mohit Agrawal <moagrawa@redhat.com>
Date:   Wed Jun 29 15:36:41 2016 +0530

    gluster v set help does not show ssl options
    
    Problem: "gluster v set help" does not show ssl options.
    
    Solution: Remove NO_DOC option for client.ssl/server.ssl from glusterd_volopt_map.
    
    Backport of commit 9733c68e878869daec196bf7bca16780eef73f74
    BUG: 1365756
    Signed-off-by: Mohit Agrawal <moagrawa@redhat.com>
    
    > Change-Id: Iabe982ea56398209bbf30d41260798e5ad7fce7b
    > BUG: 1351134
    > Signed-off-by: Mohit Agrawal <moagrawa@redhat.com>
    > Reviewed-on: http://review.gluster.org/14829
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > (cherry picked from commit 9733c68e878869daec196bf7bca16780eef73f74)
    
    Change-Id: I3d521c988e6fa337e383128e847c30810fc81650
    Reviewed-on: http://review.gluster.org/15130
    Tested-by: MOHIT AGRAWAL <moagrawa@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 3 Niels de Vos 2016-08-24 10:20:46 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.3, please open a new bug report.

glusterfs-3.8.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/announce/2016-August/000059.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.