Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365743 - GlusterFS - Memory Leak - High Memory Utilization
Summary: GlusterFS - Memory Leak - High Memory Utilization
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.8.2
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 06:43 UTC by Oleksandr Natalenko
Modified: 2016-08-12 09:48 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-12 09:48:48 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Oleksandr Natalenko 2016-08-10 06:43:36 UTC
Backport of https://bugzilla.redhat.com/show_bug.cgi?id=1352854 to 3.8.

Comment 1 Vijay Bellur 2016-08-10 06:44:03 UTC
REVIEW: http://review.gluster.org/15125 (glusterd: Fix memory leak in glusterd (un)lock RPCs) posted (#1) for review on release-3.8 by Oleksandr Natalenko (oleksandr@natalenko.name)

Comment 2 Vijay Bellur 2016-08-10 10:32:31 UTC
COMMIT: http://review.gluster.org/15125 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 26471bc310db9ac010935b6fa2716ae555c6f1c7
Author: root <root@dhcp35-131.lab.eng.blr.redhat.com>
Date:   Tue Jul 5 14:33:15 2016 +0530

    glusterd: Fix memory leak in glusterd (un)lock RPCs
    
    Problem:  At the time of execute "gluster volume profile <vol> info" command
              It does have memory leak in glusterd.
    
    Solution: Modify the code to prevent memory leak in glusterd.
    
    Fix    : 1) Unref dict and free dict_val buffer in glusterd_mgmt_v3_lock_peer and
                glusterd_mgmt_v3_unlock_peers.
    
    Test   : To verify the patch run below loop to generate io traffic
             for (( i=0 ; i<=1000000 ; i++ ));
               do echo "hi Start Line " > file$i;
               cat file$i >> /dev/null;
             done
    
             To verify the improvement in memory leak specific to glusterd run below command
    
             cnt=0;while [ $cnt -le 1000 ]; do
             pmap -x <glusterd-pid> | grep total;
             gluster volume profile distributed info > /dev/null; cnt=`expr $cnt + 1`; done
    
             After apply this patch it will reduce leak significantly.
    
    > Reviewed-on: http://review.gluster.org/14862
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    > Reviewed-by: Prashanth Pai <ppai@redhat.com>
    
    BUG: 1365743
    Change-Id: I52a0ca47adb20bfe4b1848a11df23e5e37c5cea9
    Signed-off-by: Mohit Agrawal <moagrawa@redhat.com>
    Signed-off-by: Oleksandr Natalenko <oleksandr@natalenko.name>
    Reviewed-on: http://review.gluster.org/15125
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 3 Niels de Vos 2016-08-12 09:48:48 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.2, please open a new bug report.

glusterfs-3.8.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/announce/2016-August/000058.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.