Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365739 - clang compile on ppc64le error: unable to interface with target machine
Summary: clang compile on ppc64le error: unable to interface with target machine
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: llvm
Version: epel7
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Johansen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2016-08-10 06:31 UTC by Daniel Black
Modified: 2019-03-15 00:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-15 00:46:12 UTC


Attachments (Terms of Use)

Description Daniel Black 2016-08-10 06:31:19 UTC
Description of problem:

yum info clang

Installed Packages
Name        : clang
Arch        : ppc64le
Version     : 3.4.2
Release     : 8.el7
Size        : 66 M
Repo        : installed
From repo   : epel
Summary     : A C language family front-end for LLVM
URL         : http://llvm.org/
License     : NCSA
Description : clang: noun
            :     1. A loud, resonant, metallic sound.
            :     2. The strident call of a crane or goose.
            :     3. C-language family front-end toolkit.
            :
            : The goal of the Clang project is to create a new C, C++, Objective C
            : and Objective C++ front-end for the LLVM compiler. Its tools are built
            : as libraries and designed to be loosely-coupled and extensible.


Version-Release number of selected component (if applicable):

$ clang --version
clang version 3.4.2 (tags/RELEASE_34/dot2-final)
Target: powerpc64le-redhat-linux-gnu
Thread model: posix


How reproducible:


Steps to Reproduce:
1.

cat /tmp/test.c

int
main() {

return 0;
}


2.
clang -o /tmp/test.o -c  /tmp/test.c
error: unable to interface with target machine
1 error generated.

3.
$ clang -c  /tmp/test.c
error: unable to interface with target machine
1 error generated.


Actual results:

error: unable to interface with target machine

Expected results:

successful compile

Additional info:

Comment 1 Dave Johansen 2016-08-11 03:21:52 UTC
I don't have access to hardware, so please submit a patch.

Comment 2 Dan Horák 2016-09-20 15:02:57 UTC
Could be that llvm 3.4 doesn't have enough of ppc64le support. There are newer versions of llvm packaged in Fedora in separate packages, so they could be brought into EPEL as well.

Comment 3 Tom Stellard 2017-09-02 00:11:57 UTC
ppc64le was not fully supported until LLVM 3.5: http://releases.llvm.org/3.5.1/docs/ReleaseNotes.html

Comment 4 Daniel Black 2017-11-07 05:58:51 UTC
Ack. Seems to be removed from EPEL which works for me: https://apps.fedoraproject.org/packages/clang/overview/

Comment 5 Daniel Black 2019-03-15 00:46:12 UTC
Fixed by of old version from EPEL.


Note You need to log in before you can comment on or make changes to this bug.