Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365734 - Mem leak in meta_default_readv in meta xlators
Summary: Mem leak in meta_default_readv in meta xlators
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: unclassified
Version: 3.8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact:
URL:
Whiteboard:
Depends On: 1362397 1364522
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 06:06 UTC by Mohammed Rafi KC
Modified: 2016-08-24 10:20 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1364522
Environment:
Last Closed: 2016-08-24 10:20:46 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2016-08-10 06:06:39 UTC
+++ This bug was initially created as a clone of Bug #1364522 +++

+++ This bug was initially created as a clone of Bug #1362397 +++

Description of problem:

Meta xlators leaking iobuf and iobref in read code path, from the function meta_default_readv


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. create a volume and do a fuse mount
2. read the file /mnt/.meta/version in loop
3.

Actual results:

memleak

Expected results:

there should not be any memleak

Additional info:

--- Additional comment from Mohammed Rafi KC on 2016-08-02 08:50:25 CEST ---

I opened the bug in glusterd, because I couldn't find a component named meta.

--- Additional comment from Vijay Bellur on 2016-08-02 08:53:42 CEST ---

REVIEW: http://review.gluster.org/15068 (meta: fix memory leak in meta xlators) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-08-05 12:57:00 CEST ---

COMMIT: http://review.gluster.org/15068 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit d297d2bdfc4d5ba99c37b22dd1ae0f8e8e92fe7b
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Aug 2 11:59:42 2016 +0530

    meta: fix memory leak in meta xlators
    
    meta xlator is leaking iobuf and iobrefs in read path
    
    This patch fixes memleak in meta_default_read code path
    
    Change-Id: Ieb413267604d9870dbe6e11258fffd279a7bd7cf
    BUG: 1362397
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/15068
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Poornima G <pgurusid@redhat.com>

--- Additional comment from Vijay Bellur on 2016-08-05 16:06:58 CEST ---

REVIEW: http://review.gluster.org/15102 (meta: fix memory leak in meta xlators) posted (#1) for review on release-3.7 by Oleksandr Natalenko (oleksandr@natalenko.name)

Comment 1 Vijay Bellur 2016-08-10 06:12:32 UTC
REVIEW: http://review.gluster.org/15123 (meta: fix memory leak in meta xlators) posted (#1) for review on release-3.8 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Vijay Bellur 2016-08-13 08:07:56 UTC
COMMIT: http://review.gluster.org/15123 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit ba7a337ab250761492b153c1caee0c21b28e08a1
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Aug 2 11:59:42 2016 +0530

    meta: fix memory leak in meta xlators
    
    meta xlator is leaking iobuf and iobrefs in read path
    
    This patch fixes memleak in meta_default_read code path
    
    Backport of>
    >Change-Id: Ieb413267604d9870dbe6e11258fffd279a7bd7cf
    >BUG: 1362397
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/15068
    >Smoke: Gluster Build System <jenkins@build.gluster.org>
    >Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Poornima G <pgurusid@redhat.com>
    
    (cherry picked from commit d297d2bdfc4d5ba99c37b22dd1ae0f8e8e92fe7b)
    
    
    Change-Id: I1141d3770f2d0f24ac5954d12a6bb3cc4a900f44
    BUG: 1365734
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/15123
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: Oleksandr Natalenko <oleksandr@natalenko.name>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 3 Niels de Vos 2016-08-24 10:20:46 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.3, please open a new bug report.

glusterfs-3.8.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/announce/2016-August/000059.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.