Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365728 - dapltest does not work
Summary: dapltest does not work
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dapl
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Michal Schmidt
QA Contact: zguo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 05:24 UTC by zguo
Modified: 2018-11-12 14:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-19 18:47:11 UTC


Attachments (Terms of Use)

Description zguo 2016-08-10 05:24:22 UTC
Description of problem:


Version-Release number of selected component (if applicable):
RHEL-7.3-20160805.n.0 
kernel-3.10.0-485.el7.x86_64
dapl-2.1.5-2.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Job URL: https://beaker.engineering.redhat.com/recipes/2945342#task44144404
2. client log: https://beaker.engineering.redhat.com/recipes/2945342/tasks/44144404/results/217973206/logs/test_log--kernel-infiniband-dapl-client.log
3.

Actual results:
dapltest -T T -D ofa-v2-mlx5_ib0 -s ib0-qe-06 -i 500 client SR 1 1  client SR 1 1 server SR 1 1 server SR 1 1
+ timeout 15m dapltest -T T -D ofa-v2-mlx5_ib0 -s ib0-qe-06 -i 500 client SR 1 1 client SR 1 1 server SR 1 1 server SR 1 1
Server Name: ib0-qe-06 
Server Net Address: 172.31.0.6
DT_cs_Client: Starting Test ... 
rdma-qe-07:CMA:346a:864ef700: 99104 us(99104 us): dapl_cma_active: non-consumer REJ, reason=8, DST 172.31.0.6, 62000
Warning: conn_event_wait DAT_CONNECTION_EVENT_NON_PEER_REJECTED
DT_cs_Client: bad connection event
DT_cs_Client: ========== End of Work -- Client Exiting
+ '[' 0 -eq 124 ']'
+ for n in '`seq 0 15`'
++ eval /tmp/powl 2 1
+++ /tmp/powl 2 1
+ size_msg=2
+ '[' 2 -eq 0 ']'
+ echo 'dapltest -T T -D ofa-v2-mlx5_ib0 -s ib0-qe-06 -i 500 client SR 2 1  client SR 2 1 server SR 2 1 server SR 2 1'
dapltest -T T -D ofa-v2-mlx5_ib0 -s ib0-qe-06 -i 500 client SR 2 1  client SR 2 1 server SR 2 1 server SR 2 1
+ timeout 15m dapltest -T T -D ofa-v2-mlx5_ib0 -s ib0-qe-06 -i 500 client SR 2 1 client SR 2 1 server SR 2 1 server SR 2 1
Server Name: ib0-qe-06 
Server Net Address: 172.31.0.6
DT_cs_Client: Starting Test ... 
rdma-qe-07:CMA:3479:360f3700: 14466 us(14466 us): dapl_cma_active: non-consumer REJ, reason=8, DST 172.31.0.6, 62000
Warning: conn_event_wait DAT_CONNECTION_EVENT_NON_PEER_REJECTED
DT_cs_Client: bad connection event
DT_cs_Client: ========== End of Work -- Client Exiting
+ '[' 0 -eq 124 ']'
...

Expected results:


Additional info:

Comment 1 zguo 2016-08-10 05:35:00 UTC
Test against rhel-7.2 release distro, only limited test failed. But all test are not working over RHEL-7.3-20160805.n.0.

RHEL-7.2:
dapl-utils-2.1.5-1.el7.x86_64
compat-dapl-1.2.19-4.el7.x86_64
compat-dapl-utils-1.2.19-4.el7.x86_64
dapl-2.1.5-1.el7.x86_64

RHEL-7.3-20160805.n.0:
dapl-2.1.5-2.el7.x86_64
compat-dapl-1.2.19-4.el7.x86_64
compat-dapl-utils-1.2.19-4.el7.x86_64
dapl-utils-2.1.5-2.el7.x86_64

=== Log of dapltest over rhel-7.2 ===
 echo '## limited test'
## limited test
+ dapltest -T L -m 10
**********************************************************************
Limitation Test                      limit_ia
Description:  Test max num of opens for the same physical IA
LimitTest: dat_ia_open (ofa-v2-ib0) #1 fails: DAT_PROVIDER_NOT_FOUND DAT_NAME_NOT_REGISTERED
LimitTest: IAs opened: 0
**********************************************************************
**********************************************************************
Limitation Test                      limit_pz
Description:  Test max num of PZs that are supported by an IA
LimitTest: dat_ia_open (ofa-v2-ib0) #1 fails: DAT_PROVIDER_NOT_FOUND DAT_NAME_NOT_REGISTERED
error occurs, can not continue with limit test
**********************************************************************
+ dapltest -T L -m 1000
**********************************************************************
Limitation Test                      limit_ia
Description:  Test max num of opens for the same physical IA
LimitTest: dat_ia_open (ofa-v2-ib0) #1 fails: DAT_PROVIDER_NOT_FOUND DAT_NAME_NOT_REGISTERED
LimitTest: IAs opened: 0
**********************************************************************
**********************************************************************
Limitation Test                      limit_pz
Description:  Test max num of PZs that are supported by an IA
LimitTest: dat_ia_open (ofa-v2-ib0) #1 fails: DAT_PROVIDER_NOT_FOUND DAT_NAME_NOT_REGISTERED
error occurs, can not continue with limit test
**********************************************************************
+ echo '--- client finishes.'

Test job for rhel-7.2:
https://beaker.engineering.redhat.com/jobs/1440800
https://beaker.engineering.redhat.com/recipes/2950332/tasks/44193854/results/218055994/logs/test_log--kernel-infiniband-dapl-client.log

Comment 4 Michal Schmidt 2016-08-30 12:10:46 UTC
The only change in dapl between RHEL 7.2 and 7.3 was this commit from Honggang:
http://pkgs.devel.redhat.com/cgit/rpms/dapl/commit/?h=rhel-7.3&id=6362e042869c1affcf4aaeef93146ab314bbd792

Does RHEL 7.3 work if you downgrade dapl to the version from 7.2? (Or alternatively, does RHEL 7.2 break if you upgrade only dapl to the version from 7.3?)

Comment 5 zguo 2016-09-01 02:41:57 UTC
7.3 + dapl from 7.2,        test failed, https://beaker.engineering.redhat.com/jobs/1480918
7.3 + latest dapl from 7.3, test failed, https://beaker.engineering.redhat.com/jobs/1480663

7.2 + dapl from 7.2,          test passed, https://beaker.engineering.redhat.com/jobs/1440800 
7.2 + latest dapl from 7.3,   test passed, https://beaker.engineering.redhat.com/jobs/1480595

Comment 6 Michal Schmidt 2016-09-14 10:19:37 UTC
This works for me on rdma-dev-02/03, which are also Connect-IB (mlx5) systems (like rdma-qe-06/07), with RHEL-7 nightly from Sep 13.
Could you please retest?


Note You need to log in before you can comment on or make changes to this bug.