Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365723 - nikola build throws ImportError: No module named piexif
Summary: nikola build throws ImportError: No module named piexif
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: python-nikola
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pete Travis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1372345
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-10 04:44 UTC by Viorel Tabara
Modified: 2017-08-08 16:22 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-08 16:22:46 UTC


Attachments (Terms of Use)

Description Viorel Tabara 2016-08-10 04:44:18 UTC
Description of problem:

Cannot build.


Version-Release number of selected component (if applicable):

python2-nikola-7.7.12-1.fc24.noarch


How reproducible:

Always.


Steps to Reproduce:

1. For an existing setup run the build command:

        nikola build

Actual results:

   [2016-08-10T04:18:51Z] ERROR: yapsy: Unable to import plugin: /usr/lib/python2.7/site-packages/nikola/plugins/task/galleries
   Traceback (most recent call last):
   File "/usr/lib/python2.7/site-packages/yapsy/PluginManager.py", line 488, in loadPlugins
      candidate_module = imp.load_module(plugin_module_name,plugin_file,candidate_filepath+".py",("py","r",imp.PY_SOURCE))
   File "/usr/lib/python2.7/site-packages/nikola/plugins/task/galleries.py", line 52, in <module>
      from nikola.image_processing import ImageProcessor
   File "/usr/lib/python2.7/site-packages/nikola/image_processing.py", line 36, in <module>
      import piexif
   ImportError: No module named piexif
   [2016-08-10T04:18:51Z] ERROR: yapsy: Unable to import plugin: /usr/lib/python2.7/site-packages/nikola/plugins/task/scale_images
   Traceback (most recent call last):
   File "/usr/lib/python2.7/site-packages/yapsy/PluginManager.py", line 488, in loadPlugins
      candidate_module = imp.load_module(plugin_module_name,plugin_file,candidate_filepath+".py",("py","r",imp.PY_SOURCE))
   File "/usr/lib/python2.7/site-packages/nikola/plugins/task/scale_images.py", line 32, in <module>
      from nikola.image_processing import ImageProcessor
   File "/usr/lib/python2.7/site-packages/nikola/image_processing.py", line 36, in <module>
      import piexif
   ImportError: No module named piexif
   

Expected results:

No error.

Additional info:

[root@omiday ~]# dnf history info 91
Transaction ID : 91
Begin time     : Tue Aug  9 21:52:08 2016
Begin rpmdb    : 2218:a44c41c3876716419c7aee3f4e47b927715b3a81
End time       :            21:52:17 2016 (9 seconds)
End rpmdb      : 2218:edc8e6834968e101841babb8ff7e49bda4c7ed63
User           :  <lelu>
Return-Code    : Success
Command Line   : upgrade
Transaction performed with:
    Installed     dnf-1.1.9-2.fc24.noarch         @anaconda
    Installed     rpm-4.13.0-0.rc1.27.fc24.x86_64 @anaconda
Packages Altered:
    Upgraded   augeas-libs-1.5.0-1.fc24.x86_64            @anaconda
    Upgrade                1.6.0-1.fc24.x86_64            @updates-testing
    Upgraded   avahi-0.6.32-1.fc24.x86_64                 @anaconda
    Upgrade          0.6.32-4.fc24.x86_64                 @updates-testing
    Upgraded   avahi-glib-0.6.32-1.fc24.x86_64            @anaconda
    Upgrade               0.6.32-4.fc24.x86_64            @updates-testing
    Upgraded   avahi-libs-0.6.32-1.fc24.x86_64            @anaconda
    Upgrade               0.6.32-4.fc24.x86_64            @updates-testing
    Upgraded   avahi-ui-gtk3-0.6.32-1.fc24.x86_64         @fedora
    Upgrade                  0.6.32-4.fc24.x86_64         @updates-testing
    Upgraded   fedora-repos-24-1.noarch                   @anaconda
    Upgrade                 24-2.noarch                   @updates-testing
    Upgraded   ibus-libpinyin-1.7.92-1.fc24.x86_64        @updates-testing
    Upgrade                   1.7.92-2.fc24.x86_64        @updates-testing
    Upgraded   libpinyin-1.5.92-1.fc24.x86_64             @updates-testing
    Upgrade              1.5.92-2.fc24.x86_64             @updates-testing
    Upgraded   libpinyin-data-1.5.92-1.fc24.x86_64        @updates-testing
    Upgrade                   1.5.92-2.fc24.x86_64        @updates-testing
    Upgraded   openssh-7.2p2-11.fc24.x86_64               @updates
    Upgrade            7.2p2-12.fc24.x86_64               @updates-testing
    Upgraded   openssh-askpass-7.2p2-11.fc24.x86_64       @updates
    Upgrade                    7.2p2-12.fc24.x86_64       @updates-testing
    Upgraded   openssh-clients-7.2p2-11.fc24.x86_64       @updates
    Upgrade                    7.2p2-12.fc24.x86_64       @updates-testing
    Upgraded   openssh-server-7.2p2-11.fc24.x86_64        @updates
    Upgrade                   7.2p2-12.fc24.x86_64        @updates-testing
    Upgraded   perl-Archive-Zip-1.57-1.fc24.noarch        @fedora
    Upgrade                     1.58-1.fc24.noarch        @updates-testing
    Upgraded   perl-ExtUtils-Command-7.10-4.fc24.noarch   @fedora
    Upgrade                          7.10-5.fc24.noarch   @updates-testing
    Upgraded   perl-ExtUtils-MM-Utils-7.10-4.fc24.noarch  @fedora
    Upgrade                           7.10-5.fc24.noarch  @updates-testing
    Upgraded   perl-ExtUtils-MakeMaker-7.10-4.fc24.noarch @fedora
    Upgrade                            7.10-5.fc24.noarch @updates-testing
    Obsoleted  python-nikola-7.7.9-2.fc24.noarch          @updates
    Upgraded   python-nikola-doc-7.7.11-3.fc24.noarch     @updates-testing
    Upgrade                      7.7.12-1.fc24.noarch     @updates-testing
    Obsoleted  python-nikola-extras-7.7.9-2.fc24.noarch   @updates
    Obsoleting python2-nikola-7.7.12-1.fc24.noarch        @updates-testing
    Install    python2-nikola-7.7.12-1.fc24.noarch        @updates-testing
    Obsoleting python2-nikola-extras-7.7.12-1.fc24.noarch @updates-testing
    Install    python2-nikola-extras-7.7.12-1.fc24.noarch @updates-testing
    Upgraded   nfs-utils-1:1.3.3-8.rc5.fc24.x86_64        @anaconda
    Upgrade              1:1.3.4-0.fc24.x86_64            @updates-testing


[root@omiday ~]# dnf history undo 91
Last metadata expiration check: 1:13:01 ago on Tue Aug  9 21:03:31 2016.
Undoing transaction 91, from Tue Aug  9 21:52:08 2016
    Upgraded   augeas-libs-1.5.0-1.fc24.x86_64            @anaconda
    Upgrade                1.6.0-1.fc24.x86_64            @updates-testing
    Upgraded   avahi-0.6.32-1.fc24.x86_64                 @anaconda
    Upgrade          0.6.32-4.fc24.x86_64                 @updates-testing
    Upgraded   avahi-glib-0.6.32-1.fc24.x86_64            @anaconda
    Upgrade               0.6.32-4.fc24.x86_64            @updates-testing
    Upgraded   avahi-libs-0.6.32-1.fc24.x86_64            @anaconda
    Upgrade               0.6.32-4.fc24.x86_64            @updates-testing
    Upgraded   avahi-ui-gtk3-0.6.32-1.fc24.x86_64         @fedora
    Upgrade                  0.6.32-4.fc24.x86_64         @updates-testing
    Upgraded   fedora-repos-24-1.noarch                   @anaconda
    Upgrade                 24-2.noarch                   @updates-testing
    Upgraded   ibus-libpinyin-1.7.92-1.fc24.x86_64        @updates-testing
    Upgrade                   1.7.92-2.fc24.x86_64        @updates-testing
    Upgraded   libpinyin-1.5.92-1.fc24.x86_64             @updates-testing
    Upgrade              1.5.92-2.fc24.x86_64             @updates-testing
    Upgraded   libpinyin-data-1.5.92-1.fc24.x86_64        @updates-testing
    Upgrade                   1.5.92-2.fc24.x86_64        @updates-testing
    Upgraded   openssh-7.2p2-11.fc24.x86_64               @updates
    Upgrade            7.2p2-12.fc24.x86_64               @updates-testing
    Upgraded   openssh-askpass-7.2p2-11.fc24.x86_64       @updates
    Upgrade                    7.2p2-12.fc24.x86_64       @updates-testing
    Upgraded   openssh-clients-7.2p2-11.fc24.x86_64       @updates
    Upgrade                    7.2p2-12.fc24.x86_64       @updates-testing
    Upgraded   openssh-server-7.2p2-11.fc24.x86_64        @updates
    Upgrade                   7.2p2-12.fc24.x86_64        @updates-testing
    Upgraded   perl-Archive-Zip-1.57-1.fc24.noarch        @fedora
    Upgrade                     1.58-1.fc24.noarch        @updates-testing
    Upgraded   perl-ExtUtils-Command-7.10-4.fc24.noarch   @fedora
    Upgrade                          7.10-5.fc24.noarch   @updates-testing
    Upgraded   perl-ExtUtils-MM-Utils-7.10-4.fc24.noarch  @fedora
    Upgrade                           7.10-5.fc24.noarch  @updates-testing
    Upgraded   perl-ExtUtils-MakeMaker-7.10-4.fc24.noarch @fedora
    Upgrade                            7.10-5.fc24.noarch @updates-testing
    Obsoleted  python-nikola-7.7.9-2.fc24.noarch          @updates
    Upgraded   python-nikola-doc-7.7.11-3.fc24.noarch     @updates-testing
    Upgrade                      7.7.12-1.fc24.noarch     @updates-testing
    Obsoleted  python-nikola-extras-7.7.9-2.fc24.noarch   @updates
    Obsoleting python2-nikola-7.7.12-1.fc24.noarch        @updates-testing
    Install    python2-nikola-7.7.12-1.fc24.noarch        @updates-testing
    Obsoleting python2-nikola-extras-7.7.12-1.fc24.noarch @updates-testing
    Install    python2-nikola-extras-7.7.12-1.fc24.noarch @updates-testing
    Upgraded   nfs-utils-1:1.3.3-8.rc5.fc24.x86_64        @anaconda
    Upgrade              1:1.3.4-0.fc24.x86_64            @updates-testing
No package python-nikola-extras-0:7.7.9-2.fc24.noarch available.
Error: An operation cannot be undone

Comment 1 Adam Williamson 2016-08-10 18:09:27 UTC
It looks like this dep was recently added to nikola upstream:

https://github.com/getnikola/nikola/commit/2b1ec3d9ff7748d1fc270bd74ba49748afe5cb41

it is not packaged for Fedora AFAICS, so it would need to be packaged and reviewed. Nice catch, Viorel.

Comment 2 Adam Williamson 2016-08-10 18:09:57 UTC
BTW, I'm curious why package updates - including new releases - are being built for F24, but not any other branch (inc. Rawhide and F25).

Comment 3 José Matos 2016-08-11 08:37:38 UTC
(In reply to Adam Williamson from comment #2)
> BTW, I'm curious why package updates - including new releases - are being
> built for F24, but not any other branch (inc. Rawhide and F25).

Hi Adam,
  nikola was retired in March, and I have decided to revive it on June.

There is a new review request:
https://bugzilla.redhat.com/show_bug.cgi?id=1353169

That is why the releases are happening on F24 and not on more recent versions.

Comment 4 Soliard, Adrian D. 2016-08-25 14:17:42 UTC
Hi everyone

I just installed python-nikola package in my desktop computer and get exactly the same error, this is not happening in the laptop, where I've installed python-nikola since a time ago.

In this moment I'm looking for "piexif" in the laptop, where nikola works without error.

I see this in the laptop:
/usr/lib/python2.7/site-packages/nikola/image_processing.py
...
"""Process images."""

from __future__ import unicode_literals
import datetime
import os
import lxml
import re
import gzip

from nikola import utils
...

And this in the desktop:
/usr/lib/python2.7/site-packages/nikola/image_processing.py
...
"""Process images."""

from __future__ import unicode_literals
import datetime
import os
import lxml
import re
import gzip

import piexif

from nikola import utils
...

So, if I comment the line "import piexif", then nikola works well

Regards

Comment 5 José Matos 2016-09-13 12:28:11 UTC
(In reply to Soliard, Adrian D. from comment #4)
> Hi everyone
> 
> I just installed python-nikola package in my desktop computer and get
> exactly the same error, this is not happening in the laptop, where I've
> installed python-nikola since a time ago.
> 
> In this moment I'm looking for "piexif" in the laptop, where nikola works
> without error.
> 
> ...
> 
> So, if I comment the line "import piexif", then nikola works well
> 
> Regards

Thank you for your report.

piexif is supposed to work with the exif (photos metadata) from images. So if you do not have photos/galleries in your site you should be fine.

Meanwhile I have submitted python-piexif for inclusion in Fedora and that should fix this problem.

Comment 6 Fedora End Of Life 2017-07-25 22:20:22 UTC
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 7 Fedora End Of Life 2017-08-08 16:22:46 UTC
Fedora 24 changed to end-of-life (EOL) status on 2017-08-08. Fedora 24 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.