Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365687 - [RFE] oVirt engine UI responsive design improvements
Summary: [RFE] oVirt engine UI responsive design improvements
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.Core
Version: 4.0.0
Hardware: noarch
OS: All
unspecified
low vote
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: Greg Sheremeta
QA Contact: Pavel Novotny
URL:
Whiteboard:
Depends On: ovirt_ui_redesign
Blocks: 1363900
TreeView+ depends on / blocked
 
Reported: 2016-08-09 21:07 UTC by Greg Sheremeta
Modified: 2017-12-22 06:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-12-22 06:50:52 UTC
oVirt Team: UX
rule-engine: ovirt-4.2?
pnovotny: testing_plan_complete-
rule-engine: planning_ack?
rule-engine: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
skinny window - app distorted (deleted)
2016-08-09 21:07 UTC, Greg Sheremeta
no flags Details
web UI - mobile-like resolution look (deleted)
2017-12-20 20:46 UTC, Pavel Novotny
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 75669 None None None 2017-06-07 11:56:50 UTC

Description Greg Sheremeta 2016-08-09 21:07:44 UTC
Created attachment 1189418 [details]
skinny window - app distorted

Description of problem:
This is an [RFE] for oVirt engine UI responsive design improvements

Version-Release number of selected component (if applicable):
4.0

How reproducible:
always

Steps to Reproduce:
There are several responsive design issues. A more thorough review session needs to take place, but some low hanging fruit:
 * resize a login screen to < 700px, and the form doesn't behave well
 * resize the welcome page to be very short and a strange vertical scroll bar appears
 * resize the main app to < 500px and it does some nasty stuff as it drops into mobile mode (see screenshot) 

I recommend a design review with the PatternFly team, and using this BZ as an "epic" or tracker for responsiveness issues we find.

Comment 1 Greg Sheremeta 2016-08-09 21:09:41 UTC
See also: https://bugzilla.redhat.com/show_bug.cgi?id=1347807#c5

Comment 2 Red Hat Bugzilla Rules Engine 2016-08-11 12:08:01 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 3 Yaniv Kaul 2016-10-23 07:04:39 UTC
Any updates on this?

Comment 4 Greg Sheremeta 2016-10-25 12:29:49 UTC
Yes, Serena and I have been in contact. I hope to pick this up after our epic on memory leaks is solved.

Comment 9 Alexander Wels 2017-06-07 11:59:33 UTC
Everything but the first issue noted has been taken care of. In particular when you make the login screen small enough to fit on mobile screen the label and field are switched for user name and password but not the profile selection.

Comment 10 Greg Sheremeta 2017-06-07 12:16:00 UTC
The first issue can be tracked in Bug 1457951

Comment 11 Pavel Novotny 2017-12-20 20:44:49 UTC
Verified in
ovirt-engine-4.2.0.2-0.1.el7.noarch
ovirt-engine-webadmin-portal-4.2.0.2-0.1.el7.noarch

I resized the browser window to 480 x 800 px (most common resolution for older mobile devices) and went through different areas of the web UI:
- welcome page
- login screen
- Webadmin - Dashboard, dialogs, main views and detail views with various widgets

I have not found any distorted parts on the page.
All the dialogs, data tables, menu buttons, Dashboard, etc., always aligned or stacked nicely - nothing was overflowing or cut off -
of horizontal/vertical scrollbars appeared.
See the attached panoramic screenshot for details.

Comment 12 Pavel Novotny 2017-12-20 20:46:15 UTC
Created attachment 1370575 [details]
web UI - mobile-like resolution look

Comment 13 Pavel Novotny 2017-12-20 21:01:54 UTC
I forgot to add:
tested with Firefox 52 ESR & 58 beta and Chromium 63.

Comment 14 Sandro Bonazzola 2017-12-22 06:50:52 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.