Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365672 - Custom product subscription shows up as "null" on activation key, unable to attach
Summary: Custom product subscription shows up as "null" on activation key, unable to a...
Keywords:
Status: CLOSED DUPLICATE of bug 1362194
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Activation Keys
Version: 6.2.0
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 19:56 UTC by Taft Sanders
Modified: 2017-04-25 16:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-17 00:58:14 UTC


Attachments (Terms of Use)

Description Taft Sanders 2016-08-09 19:56:35 UTC
Description of problem:
Custom product subscription shows up as "null" on activation key, unable to attach. Results in error: undefined method `redhat?' for nil:NilClass

Version-Release number of selected component (if applicable):
6.2.0

How reproducible:
everytime

Steps to Reproduce:
1.Create custom product
2.Create activation key
3.Add custom product subscription to activation key

Actual results:
undefined method `redhat?' for nil:NilClass

Expected results:
Custom subscription added to activation key

Additional info:
Workaround: Register client without activation key. Manually attach custom subscription to client.

Comment 5 Brad Buckingham 2016-08-17 00:58:14 UTC

*** This bug has been marked as a duplicate of bug 1362194 ***


Note You need to log in before you can comment on or make changes to this bug.