Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365663 - Openvpn wont connect nm-openvpn[1963]: Bad LZO decompression header byte: 42
Summary: Openvpn wont connect nm-openvpn[1963]: Bad LZO decompression header byte: 42
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-nm
Version: 24
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jan Grulich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1355688
TreeView+ depends on / blocked
 
Reported: 2016-08-09 19:19 UTC by Randy Barlow
Modified: 2016-08-31 12:22 UTC (History)
6 users (show)

Fixed In Version: plasma-nm-5.7.3-2.fc24 plasma-nm-5.7.3-2.fc25 plasma-nm-5.7.3-2.fc23
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-13 20:21:35 UTC
thaller: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 365816 None None None 2016-08-09 20:21:58 UTC

Description Randy Barlow 2016-08-09 19:19:02 UTC
Description of problem:
I am unable to use my company's OpenVPN server with KDE's NetworkManager plasma widget. The connection can be established, but no further packets can be delivered in either direction. The logs have messages that say "Bad LZO decompression header byte".

This bug was originally reported against NetworkManager-openvpn[0], but a user there has identified an upstream patch[1] in plasma-nm that fixes the issue. I have not personally tested the patch, but if you are willing to submit a Bodhi update for plasma-nm I'm happy to test for you.


Version-Release number of selected component (if applicable):
plasma-nm-5.7.3-1.fc24.x86_64


How reproducible:
Every time


Steps to Reproduce:
1. Try to establish a VPN connection with a server that does not support LZO.


Actual results:
No network traffic can be delivered over the VPN.


Expected results:
I should be able to connect to hosts on the other end of the connection.


Additional info:
[0] https://bugzilla.redhat.com/show_bug.cgi?id=1355688
[1] https://quickgit.kde.org/?p=plasma-nm.git&a=commit&h=31bcd5f2cffd1c19fbd10ab0f4172f2d82eff194

Comment 1 Rex Dieter 2016-08-09 20:21:58 UTC
Looks like the upstream commit landed only in master/ branch (to become 5.8) not 5.7 branch.

Comment 2 Rex Dieter 2016-08-09 20:48:26 UTC
The fix (may?) involve UI changes, which may explain it.  Though, having to wait till Oct 18 for plasma-5.8.0 seems unfortunate too.

I'll let Jan decide what's best to do here.

Comment 3 Jan Grulich 2016-08-10 07:32:47 UTC
It's in master only because the change has UI changes, but it can be simply backported. I'll do that.

Comment 4 Fedora Update System 2016-08-10 08:24:07 UTC
plasma-nm-5.7.3-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9a6a58a5c9

Comment 5 Fedora Update System 2016-08-10 08:24:14 UTC
plasma-nm-5.7.3-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-36b6ce9444

Comment 6 Fedora Update System 2016-08-10 08:24:20 UTC
plasma-nm-5.7.3-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d538a49f7b

Comment 7 Fedora Update System 2016-08-10 18:55:24 UTC
plasma-nm-5.7.3-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d538a49f7b

Comment 8 Fedora Update System 2016-08-10 19:53:14 UTC
plasma-nm-5.7.3-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-36b6ce9444

Comment 9 Fedora Update System 2016-08-11 03:24:42 UTC
plasma-nm-5.7.3-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9a6a58a5c9

Comment 10 Thomas Haller 2016-08-11 14:30:57 UTC
the fix in plasma-nm is not sufficient, because existing connections are still broken.

The change in behavior how comp-lzo is interpreted has also issues for a user who downgrades to an older plasma-nm version. I think that should be avoided.

Thus I reverted how nm-openvpn treats "comp-lzo=no", see https://bugzilla.gnome.org/show_bug.cgi?id=769177#c7



With this change, the "No" option in plasma-nm's comp-lzo combo-box is broken again. plasma-nm should be fixed to set "no-by-default" instead of "no".

Comment 11 Thomas Haller 2016-08-11 14:44:55 UTC
(In reply to Thomas Haller from comment #10)

@Jan, never mind, I opened upstream KDE bug https://bugs.kde.org/show_bug.cgi?id=366640 with this issue.

This follow up issue doesn't have high priority for Fedora as it only results in the "No" option to be treated wrongly.

Comment 12 Randy Barlow 2016-08-11 15:29:29 UTC
I noted this in Bodhi, but I'll repeat here too:

Thomas is correct that existing connections are still broken after upgrading to this patch. However, in my case I was able to edit the connection and uncheck the LZO checkbox, save the connection, and get going again.

I decided to give the update positive karma because it did get my VPN working again (without having to downgrade NetworkManager-openvpn!) despite also requiring manual intervention from me.

If there is a way to avoid the manual intervention that you can think of, I encourage you to consider that option. I'm happy to keep testing for you, and I'm personally happy that I have a working VPN connection again in the meantime ☺

Comment 13 Thomas Haller 2016-08-12 12:45:23 UTC
(In reply to Randy Barlow from comment #12)

> If there is a way to avoid the manual intervention that you can think of, I
> encourage you to consider that option. I'm happy to keep testing for you,
> and I'm personally happy that I have a working VPN connection again in the
> meantime ☺

Hi Randy,

avoiding manual interaction can only be done in network-manager-openvpn package (not plasma-nm), by treating such connections the way it used to do.
That is already done upstream and will be fixed with bug 1355688, which already/soon has updated packages in testing (see there).

Best, Thomas

Comment 14 Fedora Update System 2016-08-13 20:21:31 UTC
plasma-nm-5.7.3-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2016-08-30 18:19:23 UTC
plasma-nm-5.7.3-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2016-08-31 12:22:45 UTC
plasma-nm-5.7.3-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.