Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365643 - qemu-kvm-rhev: -cpu host,compat=power7 doesn't work with pseries-rhel7.3.0 machine type
Summary: qemu-kvm-rhev: -cpu host,compat=power7 doesn't work with pseries-rhel7.3.0 ma...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: ppc64le
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: David Gibson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1365647
TreeView+ depends on / blocked
 
Reported: 2016-08-09 17:51 UTC by Andrea Bolognani
Modified: 2016-08-10 23:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-10 23:08:55 UTC


Attachments (Terms of Use)

Description Andrea Bolognani 2016-08-09 17:51:34 UTC
Up until very recently, one could use

  -cpu host,compat=power7

on a POWER8 host to get a POWER7 CPU in the guest; now the flag
is ignored and the guest CPU ends up being the same as the host
CPU.

According to [1]:

> Prior to QEMU-2.7, to start a guest with POWER7 CPU model on
> say a POWER8 host, it was sufficient to specify compat option
> like this:
> 
> -cpu host,compat=power7
> 
> However with QEMU-2.7, compat option will have to be
> specified using -global option so that the specified compat
> level is applied uniformly to boot CPUs as well as hotplugged
> CPUs.
> 
> -cpu host \
> -global driver=host-powerpc64-cpu,property=compat,value=power7

This change doesn't break existing guests because the
pseries-rhel7.2.0 machine type still behaves the old way, but
new guests using the pseries-rhel7.3.0 machine type will get
a POWER8 CPU instead of the POWER7 CPU they expect.


[1] https://raobharata.wordpress.com/2016/08/09/cpu-hotplug-support-in-powerkvm/
    Search for "CPU compat option" for the relevant bits

Comment 2 Andrea Bolognani 2016-08-09 17:54:12 UTC
Forgot to add package versions:

  kernel-3.10.0-485.el7.ppc64le
  qemu-kvm-rhev-2.6.0-19.el7.ppc64le

Comment 5 Thomas Huth 2016-08-10 15:02:28 UTC
Related upstream discussion: http://lists.nongnu.org/archive/html/qemu-devel/2016-08/msg02027.html

Comment 6 Karen Noel 2016-08-10 23:08:55 UTC
Not supported with RHEV for Power, therefore not a regression or blocker for RHEL 7.3. Close as won't fix.


Note You need to log in before you can comment on or make changes to this bug.