Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365603 - Image upload: cancel upload (during the upload) caused uncaught exception
Summary: Image upload: cancel upload (during the upload) caused uncaught exception
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.0.2.4
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: ovirt-4.0.6
: ---
Assignee: Daniel Erez
QA Contact: Natalie Gavrielov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 16:26 UTC by Natalie Gavrielov
Modified: 2016-11-22 11:08 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-31 12:55:36 UTC
oVirt Team: Storage
amureini: ovirt-4.0.z?
ylavi: planning_ack+
ngavrilo: devel_ack?
ngavrilo: testing_ack?


Attachments (Terms of Use)
snapshot, ui.log, engine.log, vdsm.log (deleted)
2016-08-09 16:26 UTC, Natalie Gavrielov
no flags Details
image-proxy.log (deleted)
2016-08-09 16:57 UTC, Natalie Gavrielov
no flags Details

Description Natalie Gavrielov 2016-08-09 16:26:25 UTC
Created attachment 1189355 [details]
snapshot, ui.log, engine.log, vdsm.log

Description of problem:
As part of a test I've, uploaded a few disk images (4 to be exact), and cancelled the uploads one by one, during one of the cancellation operations uncaught exception occurred.

Version-Release number of selected component:
vdsm-4.18.10-1.el7ev.x86_64
ovirt-imageio-daemon-0.3.0-0.el7ev.noarch
ovirt-imageio-common-0.3.0-0.el7ev.noarch
rhevm-4.0.2.4-0.1.el7ev.noarch
ovirt-imageio-proxy-0.3.0-0.el7ev.noarch

How reproducible:
Not sure yet.

Steps to Reproduce:
1. Upload a few disk images.
2. during the transfer of data, cancel the uploaded (one by one).

Actual results:
out of 4 uploads, 3 were cancelled successfully the remaining one threw the following:
UI:
Uncaught exception occurred. Please try reloading the page. Details: Index: 0, Size: 0
Please have your administrator check the UI logs

engine.log:
2016-08-09 18:59:16,302 ERROR [org.ovirt.engine.core.utils.servlet.ServletUtils] (default task-16) [] Can't read file '/usr/share/ovirt-engine/ui-plugins/dashboard-resources/rcue-additions.min.css.map' for request '/ovirt-engine/webadmin/plugin/dashboard/rcue-additions.min.css.map', will send a 404 error response.
2016-08-09 18:59:16,310 ERROR [org.ovirt.engine.core.utils.servlet.ServletUtils] (default task-16) [] Can't read file '/usr/share/ovirt-engine/ui-plugins/dashboard-resources/rcue.min.css.map' for request '/ovirt-engine/webadmin/plugin/dashboard/rcue.min.css.map', will send a 404 error response.

Expected results:
No exceptions.

Additional info:
The upload was indeed cancelled, I'm just concerned with the exception.

Comment 1 Natalie Gavrielov 2016-08-09 16:57:47 UTC
Created attachment 1189359 [details]
image-proxy.log

Comment 2 Daniel Erez 2016-09-11 11:45:13 UTC
@Oved - the reported errors are originated from the dashboard/reports service, is that a known issue?

Comment 3 Oved Ourfali 2016-09-13 05:37:14 UTC
(In reply to Daniel Erez from comment #2)
> @Oved - the reported errors are originated from the dashboard/reports
> service, is that a known issue?

Greg - have you seen those before?
Anyway, unrelated to the bug, but let's make sure we're good.

Comment 4 Greg Sheremeta 2016-09-13 05:47:23 UTC
(In reply to Oved Ourfali from comment #3)
> (In reply to Daniel Erez from comment #2)
> > @Oved - the reported errors are originated from the dashboard/reports
> > service, is that a known issue?
> 
> Greg - have you seen those before?
> Anyway, unrelated to the bug, but let's make sure we're good.

It only happens when you open the browser's debugger. I'd call it not a bug. We purposely don't install source maps.

Comment 5 Greg Sheremeta 2016-09-13 05:48:23 UTC
(rcue.min.css.map == a source map for rcue.min.css, requested in an attempt by the browser to de-obfuscate code)

Comment 6 Daniel Erez 2016-09-13 07:43:08 UTC
(In reply to Greg Sheremeta from comment #4)
> (In reply to Oved Ourfali from comment #3)
> > (In reply to Daniel Erez from comment #2)
> > > @Oved - the reported errors are originated from the dashboard/reports
> > > service, is that a known issue?
> > 
> > Greg - have you seen those before?
> > Anyway, unrelated to the bug, but let's make sure we're good.
> 
> It only happens when you open the browser's debugger. I'd call it not a bug.
> We purposely don't install source maps.

@Natalie - have you indeed opened the browser's debugger will producing the issue.

Comment 7 Natalie Gavrielov 2016-09-18 09:15:08 UTC
(In reply to Daniel Erez from comment #6)
> (In reply to Greg Sheremeta from comment #4)
> > (In reply to Oved Ourfali from comment #3)
> > > (In reply to Daniel Erez from comment #2)
> > > > @Oved - the reported errors are originated from the dashboard/reports
> > > > service, is that a known issue?
> > > 
> > > Greg - have you seen those before?
> > > Anyway, unrelated to the bug, but let's make sure we're good.
> > 
> > It only happens when you open the browser's debugger. I'd call it not a bug.
> > We purposely don't install source maps.
> 
> @Natalie - have you indeed opened the browser's debugger will producing the
> issue.

I usually open the debugger only after I've seen there is a problem - in the process of recreating the bug and try to supply further information.
But honestly, I can't remember.. I'll try to reproduce this on the latest build (with and without a debugger).

Comment 8 Daniel Erez 2016-10-31 12:55:36 UTC
Closing per comment #4 (the described errors shouldn't affect production mode).


Note You need to log in before you can comment on or make changes to this bug.