Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365547 - [RFE] Disable web socket role by default
Summary: [RFE] Disable web socket role by default
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: John Hardy
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 14:01 UTC by dmetzger
Modified: 2017-08-28 15:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-28 15:02:39 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Description dmetzger 2016-08-09 14:01:23 UTC
Description of problem:

The websocket role at present is needed to support VNC and SPICE HTML5 remote access consoles. It is enabled by default on all appliance and consumes about 150MB of memory initially (does appear grow over time when idle - possible memory leak - separate issue) and consumes CPU resources. For large installions the amount of memory consumed is non-trivial, think of sites with 100+ appliances. This memory is being consumed whether VNC and SPICE HTML5 remote access is being used with the appliance or not. The configuration screen text (and documentation) does not provide clear direction regarding when this role needs to be enabled for the end user.

It's understood that being enabled by default does simplify the POC process (if remote access consoles are being tested), however the memory & cpu usage is being carried by every appliance as a resource penalty if remote access console functionality is not required / used with the appliance. Also understood is that the effect of changing the default value within a available / supported release stream does carry the issue associated with the change in behavior.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Šimon Lukašík 2016-08-24 08:24:06 UTC
We need to be careful here as there are plans for Async Notification / action cable to be spun off from the web socket worker.

Perhaps we can make the worker light weight. Does it need all the rails in it?

Comment 3 Dávid Halász 2016-08-24 09:05:34 UTC
ActiveRecord is necessary.

Comment 5 Chris Pelland 2017-08-28 15:02:39 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.