Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365509 - Sat 6 server does not have all required repositories enabled
Summary: Sat 6 server does not have all required repositories enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: fusor-server
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ga
: 1.0
Assignee: Jesus M. Rodriguez
QA Contact: Tasos Papaioannou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 12:12 UTC by Thom Carlin
Modified: 2016-09-13 16:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1365540 (view as bug list)
Environment:
Last Closed: 2016-09-13 16:35:44 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description Thom Carlin 2016-08-09 12:12:29 UTC
Description of problem:

The Registration of the Sat 6 server worked but not all repositories are automatically enabled

Version-Release number of selected component (if applicable):

QCI-1.0-RHEL-7-20160808.t.0

How reproducible:

100%

Steps to Reproduce:
1. Install QCI
2. Log into run launch-fusor-installer
3. Change "15. Register Host For Updates" to true
4. Enter valid values for Username/password
5. When installation finishes: yum repolist

Actual results:

Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
repo id                                                                   repo name                                                                                                               status
rhel-7-server-eus-rpms/7Server/x86_64                                     Red Hat Enterprise Linux 7 Server - Extended Update Support (RPMs)                                                      11,189
rhel-7-server-rpms/7Server/x86_64                                         Red Hat Enterprise Linux 7 Server (RPMs)                                                                                11,198
rhel-ha-for-rhel-7-server-eus-rpms/7Server/x86_64                         Red Hat Enterprise Linux High Availability (for RHEL 7 Server) - Extended Update Support (RPMs)                            224
rhel-ha-for-rhel-7-server-rpms/7Server/x86_64                             Red Hat Enterprise Linux High Availability (for RHEL 7 Server) (RPMs)                                                      224
repolist: 22,835


Expected results:

Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
repo id                                                                          repo name                                                                                                        status
rhel-7-server-rpms/7Server/x86_64                                                Red Hat Enterprise Linux 7 Server (RPMs)                                                                         11,198
rhel-7-server-satellite-6.2-rpms/x86_64                                          Red Hat Satellite 6.2 (for RHEL 7 Server) (RPMs)                                                                    303
rhel-server-rhscl-7-rpms/7Server/x86_64                                          Red Hat Software Collections RPMs for Red Hat Enterprise Linux 7 Server                                           6,143
repolist: 17,644

Additional info:

https://access.redhat.com/documentation/en/red-hat-satellite/6.2/paged/installation-guide/chapter-3-installing-satellite-server Section 3.1.3 b

Workaround:

* yum clean all
* subscription-manager repos --disable='*'

* subscription-manager repos --enable=rhel-7-server-rpms \
--enable=rhel-server-rhscl-7-rpms \
--enable=rhel-7-server-satellite-6.2-rpms

Comment 4 John Matthews 2016-08-15 18:08:25 UTC
Might be related to the embedded product certs we install as part of ISO install

Comment 6 Jesus M. Rodriguez 2016-08-16 02:26:27 UTC
The entitlement has the following repos enabled (there are many others but these are the ones found because of the auto-attach):

Content:
        Type: yum
        Name: Red Hat Enterprise Linux 7 Server - Extended Update Support (RPMs)
        Label: rhel-7-server-eus-rpms
        Vendor: Red Hat
        URL: /content/eus/rhel/server/7/$releasever/$basearch/os
        GPG: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
        Enabled: True
        Expires: 86400
        Required Tags: rhel-7-server
        Arches: x86_64

Content:
        Type: yum
        Name: Red Hat Enterprise Linux 7 Server (RPMs)
        Label: rhel-7-server-rpms
        Vendor: Red Hat
        URL: /content/dist/rhel/server/7/$releasever/$basearch/os
        GPG: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
        Enabled: True
        Expires: 86400
        Required Tags: rhel-7-server
        Arches: x86_64

Content:
        Type: yum
        Name: Red Hat Enterprise Linux High Availability (for RHEL 7 Server) - Extended Update Support (RPMs)
        Label: rhel-ha-for-rhel-7-server-eus-rpms
        Vendor: Red Hat
        URL: /content/eus/rhel/server/7/$releasever/$basearch/highavailability/os
        GPG: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
        Enabled: True
        Expires: 86400
        Required Tags: rhel-7-server
        Arches: x86_64

Content:
        Type: yum
        Name: Red Hat Enterprise Linux High Availability (for RHEL 7 Server) (RPMs)
        Label: rhel-ha-for-rhel-7-server-rpms
        Vendor: Red Hat
        URL: /content/dist/rhel/server/7/$releasever/$basearch/highavailability/os
        GPG: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
        Enabled: True
        Expires: 86400
        Required Tags: rhel-7-server
        Arches: x86_64

Comment 7 Jesus M. Rodriguez 2016-08-16 02:27:45 UTC
The expected repos (aside from rhel-7-server-rpms) are not enabled in the certificate which is why they are not enabled by default. They are AVAILABLE.

Content:
        Type: yum
        Name: Red Hat Satellite 6.2 (for RHEL 7 Server) (RPMs)
        Label: rhel-7-server-satellite-6.2-rpms
        Vendor: Red Hat
        URL: /content/dist/rhel/server/7/7Server/$basearch/satellite/6.2/os
        GPG: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
        Enabled: False
        Expires: 86400
        Required Tags: rhel-7-server
        Arches: x86_64

Content:
        Type: yum
        Name: Red Hat Software Collections RPMs for Red Hat Enterprise Linux 7 Server
        Label: rhel-server-rhscl-7-rpms
        Vendor: Red Hat
        URL: /content/dist/rhel/server/7/$releasever/$basearch/rhscl/1/os
        GPG: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release,file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
        Enabled: False
        Expires: 86400
        Required Tags: rhel-7-server
        Arches: x86_64, ppc64le, ppc64, aarch64, s390x

Comment 11 Jesus M. Rodriguez 2016-08-23 22:12:29 UTC
https://github.com/fusor/fusor-installer/pull/89

Comment 12 Jesus M. Rodriguez 2016-08-23 22:13:33 UTC
BEFORE FIX:
[root@sat62fusor ~]# yum repolist 
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
repo id                                                                                      repo name                                                                                                                                  status
rhel-7-server-eus-rpms/7Server/x86_64                                                        Red Hat Enterprise Linux 7 Server - Extended Update Support (RPMs)                                                                         11,232
rhel-7-server-rpms/7Server/x86_64                                                            Red Hat Enterprise Linux 7 Server (RPMs)                                                                                                   11,241
rhel-ha-for-rhel-7-server-eus-rpms/7Server/x86_64                                            Red Hat Enterprise Linux High Availability (for RHEL 7 Server) - Extended Update Support (RPMs)                                               224
rhel-ha-for-rhel-7-server-rpms/7Server/x86_64                                                Red Hat Enterprise Linux High Availability (for RHEL 7 Server) (RPMs)                                                                         224
repolist: 22,921

Comment 13 Jesus M. Rodriguez 2016-08-23 22:15:54 UTC
Output from installer changed. The auto-attach still subscribes to EUS that is purely based on how the RHCI SKU is defined. But we disable all repos and enable the appropriate ones.

------
18. Cancel installation
1
Register this host with subscription manager to the customer portal for updates
Registering to: subscription.rhn.redhat.com:443/subscription
The system has been registered with ID: c3d953f6-9590-4759-b57d-566b766f7455 

Installed Product Current Status:
Product Name: Red Hat Software Collections (for RHEL Server)
Status:       Subscribed

Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

Product Name: Red Hat Satellite
Status:       Subscribed

Product Name: Red Hat Enterprise Linux Server - Extended Update Support
Status:       Subscribed


Repository 'rhel-7-server-rpms' is enabled for this system.
Repository 'rhel-7-server-satellite-6.1-rpms' is enabled for this system.
Repository 'rhel-server-rhscl-7-rpms' is enabled for this system.
This host was successfully registered!

Comment 14 Jesus M. Rodriguez 2016-08-23 22:16:16 UTC
AFTER FIX:
=======
[root@sat62fusor ~]# yum repolist
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
repo id                                                                                             repo name                                                                                                                           status
rhel-7-server-rpms/7Server/x86_64                                                                   Red Hat Enterprise Linux 7 Server (RPMs)                                                                                            11,241
rhel-7-server-satellite-6.1-rpms/x86_64                                                             Red Hat Satellite 6.1 (for RHEL 7 Server) (RPMs)                                                                                       710
rhel-server-rhscl-7-rpms/7Server/x86_64                                                             Red Hat Software Collections RPMs for Red Hat Enterprise Linux 7 Server                                                              6,279
repolist: 18,230

Comment 15 Tasos Papaioannou 2016-08-26 19:51:58 UTC
Verified on QCI-1.0-RHEL-7-20160825.t.0.

Comment 17 errata-xmlrpc 2016-09-13 16:35:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.