Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365507 - Unable to login to IPA server UI after upgrade
Summary: Unable to login to IPA server UI after upgrade
Keywords:
Status: CLOSED DUPLICATE of bug 1365572
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 12:09 UTC by Nikhil Dehadrai
Modified: 2016-08-23 12:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 12:10:14 UTC


Attachments (Terms of Use)
Error during login after upgrade from 7.0 to 7.3 (deleted)
2016-08-09 12:09 UTC, Nikhil Dehadrai
no flags Details
Internal_Error_after_httpd_restart (deleted)
2016-08-10 08:06 UTC, Nikhil Dehadrai
no flags Details
httpd_error_log_after_service_restart (deleted)
2016-08-10 08:07 UTC, Nikhil Dehadrai
no flags Details

Description Nikhil Dehadrai 2016-08-09 12:09:14 UTC
Created attachment 1189232 [details]
Error during login after upgrade from 7.0 to 7.3

Description of problem:
Unable to login to IPA server UI after upgrade from 7.0 to 7.3. 

Version-Release number of selected component (if applicable):
ipa-server-4.4.0-5.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Setup IPA server on RHEL 7.0
2. Use latest repo links for RHEL 7.3
3. Update IPA server using command "yum -y update 'ipa*' sssd"
4. After update, try login to server UI

Actual results:
After step4, user is unable to login to server UI and following meesage is displayed:

2.211 client incompatible with 2.65 server at 'https://<ipaserver_hostname>/ipa/xml'

Expected results:
No Error message should be displayed and user should be able to login successfully.

Additional info:
This issue is not observed when ipa-server is upgraded from 7.2 to 7.3.

Comment 3 Petr Vobornik 2016-08-09 16:47:51 UTC
Does Web UI work if you restart httpd service after step 3?

Comment 4 Nikhil Dehadrai 2016-08-10 08:05:52 UTC
Hi Petr,

After restarting the httpd service, the UI returned "Internal server error". Please find attached screenshot and httpd/error_logs after restarting the service.

Let me know if you need anymore details.

Comment 5 Nikhil Dehadrai 2016-08-10 08:06:38 UTC
Created attachment 1189491 [details]
Internal_Error_after_httpd_restart

Internal_Error_after_httpd_restart

Comment 6 Nikhil Dehadrai 2016-08-10 08:07:29 UTC
Created attachment 1189492 [details]
httpd_error_log_after_service_restart

httpd_error_log_after_service_restart

Comment 7 Petr Vobornik 2016-08-23 12:10:14 UTC

*** This bug has been marked as a duplicate of bug 1365572 ***


Note You need to log in before you can comment on or make changes to this bug.