Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365498 - WebUI: Tag Visibility - Wrong message displayed while accessing provider via Cluster details page
Summary: WebUI: Tag Visibility - Wrong message displayed while accessing provider via ...
Keywords:
Status: CLOSED DUPLICATE of bug 1365483
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.7.0
Assignee: Dan Clarizio
QA Contact: Ramesh A
URL:
Whiteboard: ui:tag:flash_msg
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 11:52 UTC by Ramesh A
Modified: 2016-10-17 19:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-17 19:28:31 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)
provider (deleted)
2016-08-09 11:52 UTC, Ramesh A
no flags Details

Description Ramesh A 2016-08-09 11:52:07 UTC
Created attachment 1189228 [details]
provider

Description of problem:
Wrong message displayed while accessing provider via Cluster details page

Version-Release number of selected component (if applicable):
5.6.1.0.20160726144018_810a94f 

How reproducible:
Very

Steps to Reproduce:
1. Create a new role
2. Create a new group based out of the above role.  Assign a tag in "My Company Tags" under "Assign Filters" section 
2. Create a user and assign the above role
3. As admin, navigate to Compute ==> Infrastructure ==> Clusters ==> Select a Cluster ==> Policy ==> Edit Tags ==> Assign the above used tag
4. Login as the newly created user, navigate to Compute ==> Infrastructure ==> Clusters ==> Click on the only visible cluster
5. In the Cluster details page, click on the "Infrastructure Provider" link in Relationships section

Actual results:
Displays  additional information stating "no longer exists" along with the error message.  Refer the screenshot for further information

Expected results:
Should not display this message

Additional info:

Comment 2 Harpreet Kataria 2016-10-17 19:28:31 UTC
Closing as dup this issue should be fixed with same fix for https://bugzilla.redhat.com/show_bug.cgi?id=1365483. This was fixed on upstream with https://github.com/ManageIQ/manageiq/pull/10348

*** This bug has been marked as a duplicate of bug 1365483 ***


Note You need to log in before you can comment on or make changes to this bug.