Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365494 - 'qos_specs_id' property is missing while using cinder show-type
Summary: 'qos_specs_id' property is missing while using cinder show-type
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Eric Harney
QA Contact: lkuchlan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 11:44 UTC by lkuchlan
Modified: 2016-12-14 15:50 UTC (History)
6 users (show)

Fixed In Version: openstack-cinder-9.0.0-0.20160907194411.4057701.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:50:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1512876 None None None 2016-09-19 15:46:29 UTC
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
Launchpad 1611343 None None None 2016-08-09 11:47:07 UTC

Description lkuchlan 2016-08-09 11:44:55 UTC
Description of problem:
'qos_specs_id' property is missing while using cinder show-type 

Version-Release number of selected component (if applicable):
openstack-cinder-7.0.2-2.el7ost.noarch
python-cinderclient-1.5.0-1.el7ost.noarch
python-cinder-7.0.2-2.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:

1. Create a volume type

[root@cougar01 ~(keystone_admin)]# cinder type-create iscsi
+--------------------------------------+-------+-------------+-----------+
|                  ID                  |  Name | Description | Is_Public |
+--------------------------------------+-------+-------------+-----------+
| 25db03b1-ee4f-4e3a-8808-89fd6c1399b5 | iscsi |      -      |    True   |
+--------------------------------------+-------+-------------+-----------+

2. Show volume type details

[root@cougar01 ~(keystone_admin)]# cinder type-show 25db03b1-ee4f-4e3a-8808-89fd6c1399b5
+---------------------------------+--------------------------------------+
|             Property            |                Value                 |
+---------------------------------+--------------------------------------+
|           description           |                 None                 |
|           extra_specs           |   {u'volume_backend_name': u'lvm'}   |
|                id               | 25db03b1-ee4f-4e3a-8808-89fd6c1399b5 |
|            is_public            |                 True                 |
|               name              |                iscsi                 |
| os-volume-type-access:is_public |                 True                 |
+---------------------------------+--------------------------------------+

Expected results:

'qos_specs_id' property should be displayed 
+---------------------------------+--------------------------------------+
|             Property            |                Value                 |
+---------------------------------+--------------------------------------+
|           description           |                 None                 |
|           extra_specs           |  {u'volume_backend_name': u'lvm'}    |
|                id               | 25db03b1-ee4f-4e3a-8808-89fd6c1399b5 |
|            is_public            |                 True                 |
|               name              |                iscsi                 |
| os-volume-type-access:is_public |                 True                 |
|           qos_specs_id          |                 None                 |
+---------------------------------+--------------------------------------+

Comment 3 Eric Harney 2016-09-19 15:48:15 UTC
This should be fixed in OSP10 via https://bugs.launchpad.net/cinder/+bug/1512876 .

Comment 5 lkuchlan 2016-11-27 11:11:06 UTC
Tested using:
openstack-cinder-9.0.0-12.el7ost.noarch

Verification flow:

[stack@undercloud-0 ~]$ cinder type-create iscsi      
+--------------------------------------+-------+-------------+-----------+                                                                                                    
| ID                                   | Name  | Description | Is_Public |
+--------------------------------------+-------+-------------+-----------+
| ca210075-ff7a-4543-ad2d-64dec5dbe572 | iscsi | -           | True      |
+--------------------------------------+-------+-------------+-----------+

[stack@undercloud-0 ~]$ cinder type-show ca210075-ff7a-4543-ad2d-64dec5dbe572
+---------------------------------+--------------------------------------+
| Property                        | Value                                |
+---------------------------------+--------------------------------------+
| description                     | None                                 |
| extra_specs                     | {}                                   |
| id                              | ca210075-ff7a-4543-ad2d-64dec5dbe572 |
| is_public                       | True                                 |
| name                            | iscsi                                |
| os-volume-type-access:is_public | True                                 |
| qos_specs_id                    | None                                 |
+---------------------------------+--------------------------------------+

Comment 7 errata-xmlrpc 2016-12-14 15:50:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.