Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365492 - [v3 API only]: <logical_name> property (device name for disk) found under Disks but missing from Disk
Summary: [v3 API only]: <logical_name> property (device name for disk) found under Dis...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.0.2.4
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: ovirt-4.0.4
: 4.0.4
Assignee: Idan Shaby
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 11:40 UTC by Eyal Shenitzky
Modified: 2016-09-26 12:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-26 12:36:24 UTC
oVirt Team: Storage
amureini: ovirt-4.0.z?
acanan: blocker?
eshenitz: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 61606 None None None 2016-08-09 15:36:53 UTC

Description Eyal Shenitzky 2016-08-09 11:40:58 UTC
Description of problem:
Cannot get the device name for a specific disk in a VM.

The disk name does appear under /vms/{vm:id}/disks/ collection inside <logical_name>,
But <logical_name> missing under /vms/{vm:id}/disks/{disk:id}

Version-Release number of selected component (if applicable):
4.0.2.4-0.1.el7ev

How reproducible:
100%

Steps to Reproduce:
1. Create a vm with OS and rhevm-guest-agent
2. Try to get the logical name for the disk with GET /vms/{vm:id}/disks/{disk:id}

Actual results:
There is no logical name under {disk:id}

Expected results:
logical name should appear under {disk:id}

Additional info:

Comment 1 Idan Shaby 2016-08-09 15:14:30 UTC
Allon, patch [1] that solved bug 1358271 also solves this one.
Since bug 1358271 was targeted to 4.0.4, patch [1] wasn't backported to 4.0.2.
Do we want to backport it to 4.0.2 or is it enough that it is solved in 4.0?

[1] https://gerrit.ovirt.org/#/c/61606/

Comment 2 Allon Mureinik 2016-08-09 15:36:54 UTC
I wouldn't risk 4.0.2 at this point.

Comment 3 Red Hat Bugzilla Rules Engine 2016-08-09 15:36:59 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 4 Allon Mureinik 2016-08-09 16:03:23 UTC
Also, reducing priority after f2f conversation with Raz. The original analysis seems to inaccurate, and the issue is less severe than originally thought.

Comment 5 Red Hat Bugzilla Rules Engine 2016-08-09 16:03:28 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 6 Raz Tamir 2016-09-01 14:14:16 UTC
Verified on ovirt-engine-4.0.4-0.1.el7ev.noarch
The <logical_name> exists under /vms/{vm:id}/disks/{disk:id}


Note You need to log in before you can comment on or make changes to this bug.