Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365485 - Missing shebang in the documentation of hugepages systemd script
Summary: Missing shebang in the documentation of hugepages systemd script
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Performance_Tuning_Guide
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Marek Suchanek
QA Contact: Jiri Hladky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 11:28 UTC by Hristo Mohamed
Modified: 2019-03-06 01:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 16:12:43 UTC


Attachments (Terms of Use)

Description Hristo Mohamed 2016-08-09 11:28:33 UTC
Document URL: 
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Performance_Tuning_Guide/sect-Red_Hat_Enterprise_Linux-Performance_Tuning_Guide-Memory-Configuring-huge-pages.html

Section Number and Name: 
3

Describe the issue: 
Tried the discribed systemd method, received:
 Failed at step EXEC spawning /usr/lib/systemd/hugetlb-reserve-pages: Exec format error

Expected:
Active: active (exited)

Suggestions for improvement: 
In the beginning of the bash script you are missing the :
#!/bin/sh

Additional information:

Comment 2 Marek Suchanek 2018-02-21 18:38:27 UTC
Hello Hristo,

Sorry for this taking so long. The bug was only now assigned to the correct documentation component so that I could notice it.

I've fixed the issue as you suggested:
https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/performance_tuning_guide/sect-red_hat_enterprise_linux-performance_tuning_guide-memory-configuring-huge-pages

If you're happy with the changes, I'll close this bug.

Comment 3 Marek Suchanek 2018-07-30 16:12:43 UTC
I'm assuming the issue is now fixed.

If there's still anything that needs to be changed in the documentation, feel free to reopen this bug.


Note You need to log in before you can comment on or make changes to this bug.