Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365483 - WebUI: Tag Visibility - Wrong message displayed based in tag visibility
Summary: WebUI: Tag Visibility - Wrong message displayed based in tag visibility
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Martin Povolny
QA Contact: Ramesh A
URL:
Whiteboard: ui:tag:flash_msg
: 1365498 1365522 1365573 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 11:22 UTC by Ramesh A
Modified: 2017-08-21 13:09 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-21 13:07:25 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)
provider (deleted)
2016-08-09 11:22 UTC, Ramesh A
no flags Details
resource pool (deleted)
2016-08-09 11:22 UTC, Ramesh A
no flags Details
cluster (deleted)
2016-08-09 11:23 UTC, Ramesh A
no flags Details
host (deleted)
2016-08-09 11:23 UTC, Ramesh A
no flags Details

Description Ramesh A 2016-08-09 11:22:18 UTC
Created attachment 1189220 [details]
provider

Description of problem:
Wrong message displayed based in tag visibility

Version-Release number of selected component (if applicable):
5.6.1.0.20160726144018_810a94f 

How reproducible:
Very

Steps to Reproduce:
1. Create a new role
2. Create a new group based out of the above role.  Assign a tag in "My Company Tags" under "Assign Filters" section 
2. Create a user and assign the above role
3. As admin, navigate to Compute ==> Infrastructure ==> Virtual Machines. Select an virtual machine ==> Policy ==> Edit Tags.  Assign the same tag as used in step 2
4. Login as newly created user, navigate to Compute ==> Infrastructure ==> Virtual Machine.
5. Click on the only available virtual machine to navigate to vm details page.
6. Click on following links under "Relationships" section
  a) Infrastructure Provider
  b) Cluster
  c) Host
  d) Resource Pool

Actual results:
Displays additional message along with the error message
  a) Infrastructure Provider ==> "no longer exists"
  b) Cluster ==> "no longer exists"
  c) Host ==> "Host / Node no longer exists"
  d) Resource Pool ==> "no longer exists"
Refer the screenshot for further information

Expected results:
Should not display this message

Additional info:

Comment 2 Ramesh A 2016-08-09 11:22:47 UTC
Created attachment 1189221 [details]
resource pool

Comment 3 Ramesh A 2016-08-09 11:23:10 UTC
Created attachment 1189222 [details]
cluster

Comment 4 Ramesh A 2016-08-09 11:23:50 UTC
Created attachment 1189223 [details]
host

Comment 5 Harpreet Kataria 2016-10-17 19:28:06 UTC
*** Bug 1365522 has been marked as a duplicate of this bug. ***

Comment 6 Harpreet Kataria 2016-10-17 19:28:31 UTC
*** Bug 1365498 has been marked as a duplicate of this bug. ***

Comment 7 Harpreet Kataria 2016-10-17 19:28:43 UTC
*** Bug 1365573 has been marked as a duplicate of this bug. ***

Comment 8 Harpreet Kataria 2016-10-17 19:30:52 UTC
Martin,

This was fixed on upstream with https://github.com/ManageIQ/manageiq/pull/10348
Can you look into this to see if the fix is safe to be cherry-picked on to Darga.

I have closed other 3 BZs as dup of this one as they were same issue but on different screens in UI

Thanks,
~Harpreet

Comment 9 Chris Pelland 2017-08-21 13:07:25 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Comment 10 Chris Pelland 2017-08-21 13:09:43 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.