Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365470 - SHE 3.6 RHEVH stucked in preparing to maintenance (with SHE FC storage and SHE NGN host)
Summary: SHE 3.6 RHEVH stucked in preparing to maintenance (with SHE FC storage and SH...
Keywords:
Status: CLOSED DUPLICATE of bug 1367483
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.0.4
: ---
Assignee: Dan Kenigsberg
QA Contact: Meni Yakove
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 10:58 UTC by Jiri Belka
Modified: 2016-08-17 15:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-17 15:15:52 UTC
oVirt Team: Network
amureini: ovirt-4.0.z?
rgolan: blocker?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

Description Jiri Belka 2016-08-09 10:58:58 UTC
Description of problem:

I could not set SHE host - 3.6 RHEVH-EL7 20160711.0.el7ev - whic was part of SHE env with 4.0 NGN host to maintenance.

I saw a lot of:

~~~
Thread-100746::ERROR::2016-08-09 10:38:47,615::task::866::Storage.TaskManager.Task::(_setError) Task=`d890728d-a9cd-4ad6-92b1-c3899995eadb`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 873, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/logUtils.py", line 49, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/storage/hsm.py", line 3673, in stopMonitoringDomain
    raise se.StorageDomainIsMemberOfPool(sdUUID)
StorageDomainIsMemberOfPool: Storage domain is member of pool: 'domain=cf7a884b-b0f0-4d41-aa86-c3aca18c43fc'
Thread-100746::DEBUG::2016-08-09 10:38:47,615::task::885::Storage.TaskManager.Task::(_run) Task=`d890728d-a9cd-4ad6-92b1-c3899995eadb`::Task._run: d890728d-a9cd-4ad6-92b1-c3899995eadb ('cf7a884b-b0f0-4d41-aa86-c3
aca18c43fc',) {} failed - stopping task
~~~

Version-Release number of selected component (if applicable):
4.17

How reproducible:
right now

Steps to Reproduce:
1. have SHE env with FC luns - one 3.6  RHEVH with 3.6 engine
2. add 4.0 NGN
3. hosted-engine --upgrade-appliance to upgrade engine to 4.0
4. hosted-engine --set-maintenance --mode=local on 3.6 RHEVH
5. when engine runs on NGN, move 3.6 RHEVH into maintenance

Actual results:
stucked in preparing to maintenance

Expected results:


Additional info:

Comment 2 Allon Mureinik 2016-08-10 10:29:59 UTC
Liron, can you take a look please?

Comment 3 Roy Golan 2016-08-16 07:42:13 UTC
The host monitoring keeps failing in the engine. The storage error is just noise
the code fails with NPE on switchType because its not reported by vdsm, cause it is version 3.6 

sbose@redhat.com already fixed that and this needs backporting - see Change-Id: I028cdc17207ea785f24e75f3e74d5d97d0f89306

Comment 4 Yaniv Lavi 2016-08-17 15:15:52 UTC

*** This bug has been marked as a duplicate of bug 1367483 ***


Note You need to log in before you can comment on or make changes to this bug.