Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365450 - The change of network plugin cannot take effect after updated 'networkPluginName' in master config file
Summary: The change of network plugin cannot take effect after updated 'networkPluginN...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.3.0
Hardware: All
OS: All
medium
medium
Target Milestone: ---
: ---
Assignee: Ravi Sankar
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 09:53 UTC by zhaozhanqi
Modified: 2016-09-27 09:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:43:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description zhaozhanqi 2016-08-09 09:53:12 UTC
Description of problem:
field 'networkPluginName' in master-config.yaml did not take effect when updated

Version-Release number of selected component (if applicable):
oc v3.3.0.17
kubernetes v1.3.0+507d3a7
features: Basic-Auth GSSAPI Kerberos SPNEGO

openshift v3.3.0.17
kubernetes v1.3.0+507d3a7


How reproducible:
always

Steps to Reproduce:
1. install a ose env with redhat/openshift-ovs-subnet plugin using ansilbe
2. update the network plugin to 'redhat/openshift-ovs-multitenant' in master-config.yaml
   ***snip***
  networkConfig:
  clusterNetworkCIDR: 10.2.0.0/16
  hostSubnetLength: 8
  networkPluginName: redhat/openshift-ovs-multitenant
  *****snip ****
3. restart master service
  systemctl restart atomic-openshift-master
4. check the currnet the networkplugin
   oc get clusternetwork

Actual results:

step 4. still be 'redhat/openshift-ovs-subnet'

#oc get clusternetwork
NAME      NETWORK       HOST SUBNET LENGTH   SERVICE NETWORK   PLUGIN NAME
default   10.2.0.0/16   8                    172.31.0.0/16     redhat/openshift-ovs-subnet

Expected results:

step 4. should be 'redhat/openshift-ovs-multitenant'

Additional info:

Comment 1 Ravi Sankar 2016-08-16 07:17:22 UTC
Fixed in https://github.com/openshift/origin/pull/10432

Comment 2 openshift-github-bot 2016-08-16 15:11:55 UTC
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/5cc7c6c9c0be28e2b954fafa920624796aa9e121
Bug 1365450 - Fix SDN plugin name change

Comment 3 Troy Dawson 2016-08-18 20:14:45 UTC
This has been merged into ose and is in OSE v3.3.0.22 or newer.

Comment 5 zhaozhanqi 2016-08-19 10:35:15 UTC
verified this bug on 
# openshift version
openshift v3.3.0.22
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git


it will match the master-config.yaml when get the plugin

# oc get clusternetwrok

Comment 7 errata-xmlrpc 2016-09-27 09:43:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.