Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365378 - openvswitch agents are being reported as down for 10 minutes after all reset controllers come back online
Summary: openvswitch agents are being reported as down for 10 minutes after all reset ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: async
: 8.0 (Liberty)
Assignee: John Schwarz
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On: 1359894
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 06:37 UTC by John Schwarz
Modified: 2016-09-14 14:42 UTC (History)
11 users (show)

Fixed In Version: openstack-neutron-7.1.1-5.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, if all controller nodes restarted at the same time, it would cause all amqp (rabbitmq) servers to also restart. This caused the connection between Neutron agents and the amqp servers to appear to hang until timed-out, while the time-out length is linear (60 seconds, then 120, then 240... limited at 600), preventing agents from receiving any events until the timeout expires. With this update, the timeout mechanism in the specific event that tries to connect between the agents and the neutron-server was changed to always be 60 seconds. Now, if the connection hangs because of a restart of all controller nodes, the agents recover quicker (up to 60 seconds after the controllers fully start again).
Clone Of: 1359894
Environment:
Last Closed: 2016-09-14 14:42:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1606827 None None None 2016-08-09 06:37:29 UTC
Red Hat Product Errata RHBA-2016:1872 normal SHIPPED_LIVE openstack-neutron bug fix advisory 2016-09-14 18:37:37 UTC
OpenStack gerrit 347708 None None None 2016-08-09 06:37:29 UTC

Comment 2 Toni Freger 2016-09-07 18:12:01 UTC
The issue doesn't reproduce on latest OSP8 - openstack-neutron-7.1.1-5.el7ost.noarch
Verified via steps to reproduce scenario.

Comment 4 errata-xmlrpc 2016-09-14 14:42:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1872.html


Note You need to log in before you can comment on or make changes to this bug.