Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365368 - cluster name doesn't reflect what's given in ceph-ansible 'group_vars/all' file.
Summary: cluster name doesn't reflect what's given in ceph-ansible 'group_vars/all' file.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-ansible
Version: 2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 2
Assignee: leseb
QA Contact: Rachana Patel
URL:
Whiteboard:
Depends On:
Blocks: 1371113
TreeView+ depends on / blocked
 
Reported: 2016-08-09 05:50 UTC by Bhaskarakiran
Modified: 2017-06-19 13:15 UTC (History)
17 users (show)

Fixed In Version: ceph-ansible-2.2.1-1.el7scon
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-19 13:15:15 UTC


Attachments (Terms of Use)
group_vars/all (deleted)
2016-09-19 11:52 UTC, Bhaskarakiran
no flags Details
varant_variables.yml (deleted)
2016-09-19 11:53 UTC, Bhaskarakiran
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1496 normal SHIPPED_LIVE ceph-installer, ceph-ansible, and ceph-iscsi-ansible update 2017-06-19 17:14:02 UTC

Description Bhaskarakiran 2016-08-09 05:50:35 UTC
Description of problem:
======================

Created a ceph cluster using ceph-ansible and in the 'all' file update the cluster name as "cluster: master" and the same is not getting reflecting after the configuration is done. The contents of /etc/ceph directory still shows ceph.conf file and not master.conf

The container are running on atomic hosts.

[root@dhcp43-179 ceph-ansible]# cat group_vars/all |grep cluster
cluster: master
[root@dhcp43-179 ceph-ansible]# 

Other parameters given in 'all' file :

ceph_mon_docker_username: hchen
ceph_mon_docker_imagename: rhceph2
ceph_osd_docker_username: hchen
ceph_osd_docker_imagename: rhceph2

mon_containerized_deployment: 'true'
osd_containerized_deployment: 'true'
ceph_mon_docker_interface: eth0
ceph_mon_docker_subnet: 10.70.37.0/23
ceph_osd_docker_extra_env:  "CEPH_DAEMON=OSD_CEPH_DISK,OSD_JOURNAL_SIZE=100"
ceph_osd_docker_devices: "[ '/dev/sdb', '/dev/sdc', '/dev/sdd', '/dev/sde' ]"

[root@dhcp37-41 /]# ll /etc/ceph/
total 20
-rw-------. 1 root root 137 Aug  8 10:56 ceph.client.admin.keyring
-rw-r--r--. 1 root root 841 Aug  8 10:56 ceph.conf
-rw-------. 1 ceph ceph  77 Aug  8 10:56 ceph.mon.keyring
-rw-r--r--. 1 ceph ceph 195 Aug  8 10:56 monmap

For RBD mirroring cases cluster names are needed. This blocks in verifying those all. 

Version-Release number of selected component (if applicable):
=============================================================
ceph version 10.2.2-5.el7cp (49c93ac9dceaa9318129ece8b0f45a3968d9c981)


How reproducible:
=================
100%

Steps to Reproduce:
1. Use ceph-ansible script to configure the cluster. Update the cluster name in group_vars/all file.

Actual results:


Expected results:


Additional info:

Comment 2 Daniel Gryniewicz 2016-08-09 12:16:10 UTC
https://github.com/ceph/ceph-ansible/pull/915

Comment 6 Bhaskarakiran 2016-09-12 09:19:33 UTC
The default cluster name doesn't work. I have tried couple of times with ansible as well too.

Comment 7 Daniel Gryniewicz 2016-09-12 12:55:23 UTC
Do you mean you tried with the name "ceph" and it failed?

Comment 8 Bhaskarakiran 2016-09-13 06:53:56 UTC
Yes, with the default cluster name as 'ceph', it doesn't work.

Comment 9 Alfredo Deza 2016-09-13 07:03:25 UTC
(In reply to Bhaskarakiran from comment #8)
> Yes, with the default cluster name as 'ceph', it doesn't work.

Please provide log output from ceph-ansible, output of ceph.conf and /var/lib/ceph/ contents, and anything else that might explain how this doesn't work

Comment 10 Bhaskarakiran 2016-09-14 05:38:43 UTC
The setup is no more. Will update the logs once its ready.

Comment 11 Jim Curtis 2016-09-15 03:44:45 UTC
Can you provide a copy of vagrant_variables.yml and group_vars/all, please.

Comment 12 Bhaskarakiran 2016-09-15 08:56:55 UTC
I will update the files once the setup is ready.

Comment 16 Bhaskarakiran 2016-09-19 11:52:55 UTC
Created attachment 1202458 [details]
group_vars/all

Comment 17 Bhaskarakiran 2016-09-19 11:53:23 UTC
Created attachment 1202459 [details]
varant_variables.yml

Comment 21 Andrew Schoen 2017-03-03 17:13:31 UTC
We test containerized deployments upstream now with custom cluster names, I believe this should be fixed.

Comment 25 Rachana Patel 2017-05-25 19:16:45 UTC
Verified with below version

ceph-ansible-2.2.7-1.el7scon.noarch
ansible-2.2.3.0-1.el7.noarch


Able to bring up cluster having name other than 'ceph'

Comment 27 errata-xmlrpc 2017-06-19 13:15:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1496


Note You need to log in before you can comment on or make changes to this bug.