Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365337 - Metrics collection fails for OSP providers
Summary: Metrics collection fails for OSP providers
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: C&U Capacity and Utilization
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: GA
: 5.7.0
Assignee: Marek Aufart
QA Contact: Dave Johnson
URL:
Whiteboard: c&u:openstack
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-09 00:55 UTC by Nandini Chandra
Modified: 2019-01-23 20:58 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-23 20:58:32 UTC
Category: ---
Cloudforms Team: Openstack


Attachments (Terms of Use)

Description Nandini Chandra 2016-08-09 00:55:39 UTC
Description of problem:
-----------------------
Metrics collection fails for OSP providers with this error message:

[----] E, [2016-08-08T09:29:27.719760 #15591:b11994] ERROR -- : MIQ(ManageIQ::Providers::Openstack::CloudManager::MetricsCapture#perf_collect_metrics) [realtime] for: [ManageIQ::Providers::Openstack::CloudManage
r::Vm], [58], [lkhomenk_pwr_test] Unhandled exception during perf data collection: [no implicit conversion of String into Integer], class: [TypeError]

Version-Release number of selected component (if applicable):
------------------------
5.6.1


How reproducible:
----------------
Always


Steps to Reproduce:
-------------------
1.Manage OSP provider
2.Enable C&U collection for the provider


Actual results:
---------------
Metrics collection fails for OSP providers.


Expected results:
-----------------
Metrics collection should succeed for OSP providers.


Additional info:
-----------------

Comment 2 Nandini Chandra 2016-08-09 18:57:11 UTC
[----] E, [2016-08-09T13:41:02.553116 #17085:116b998] ERROR -- : MIQ(ManageIQ::Providers::Openstack::CloudManager::MetricsCapture#perf_collect_metrics) [realtime] for: [ManageIQ::Providers::Openstack::CloudManager::Vm], [28], [nachandr-cfme56]   Timings at time of error: {:server_dequeue=>0.004283905029296875, :server_monitor=>0.17510271072387695, :capture_state=>0.3367500305175781, :connect=>0.8643429279327393}
[----] E, [2016-08-09T13:41:02.553481 #17085:116b998] ERROR -- : [Excon::Error::NotAcceptable]: Expected([200, 204, 300]) <=> Actual(406 Not Acceptable)
excon.error.response
  :body          => "{\"error_message\": \"406 Not Acceptable\\n\\nThe server could not comply with the request since it is either malformed or otherwise incorrect.\\n\\n   \"}"
  :cookies       => [
  ]
  :headers       => {
    "Content-Length" => "147"
    "Content-Type"   => "application/json"
    "Date"           => "Tue, 09 Aug 2016 17:37:55 GMT"
    "Server"         => "WSGIServer/0.1 Python/2.7.5"
  }
  :host          => "xx.yy.zz.aa"
  :local_address => "192.168.aa.bb"
  :local_port    => 36942
  :path          => "/"
  :port          => 8777
  :reason_phrase => "Not Acceptable"
  :remote_ip     => "10.8.58.50"
  :status        => 406
  :status_line   => "HTTP/1.0 406 Not Acceptable\r\n"
  Method:[rescue in perf_collect_metrics]
[----] E, [2016-08-09T13:41:02.553669 #17085:116b998] ERROR -- : /opt/rh/cfme-gemset/gems/excon-0.51.0/lib/excon/middlewares/expects.rb:6:in `response_call'
/opt/rh/cfme-gemset/gems/excon-0.51.0/lib/excon/middlewares/response_parser.rb:8:in `response_call'
/opt/rh/cfme-gemset/gems/excon-0.51.0/lib/excon/connection.rb:389:in `response'
/opt/rh/cfme-gemset/gems/excon-0.51.0/lib/excon/connection.rb:253:in `request'
/opt/rh/cfme-gemset/gems/fog-core-1.42.0/lib/fog/core/connection.rb:81:in `request'
/opt/rh/cfme-gemset/gems/fog-openstack-0.1.8/lib/fog/openstack.rb:489:in `get_supported_version'
/opt/rh/cfme-gemset/gems/fog-openstack-0.1.8/lib/fog/openstack/metering.rb:120:in `set_api_path'
/opt/rh/cfme-gemset/gems/fog-openstack-0.1.8/lib/fog/openstack/metering.rb:112:in `initialize'
/opt/rh/cfme-gemset/gems/fog-core-1.42.0/lib/fog/core/service.rb:115:in `new'
/opt/rh/cfme-gemset/gems/fog-core-1.42.0/lib/fog/core/service.rb:115:in `new'
/opt/rh/cfme-gemset/gems/fog-core-1.42.0/lib/fog/core/services_mixin.rb:16:in `new'
/var/www/miq/vmdb/gems/pending/openstack/openstack_handle/handle.rb:74:in `raw_connect'
/var/www/miq/vmdb/gems/pending/openstack/openstack_handle/handle.rb:49:in `block in raw_connect_try_ssl'
/var/www/miq/vmdb/gems/pending/openstack/openstack_handle/handle.rb:39:in `try_connection'
/var/www/miq/vmdb/gems/pending/openstack/openstack_handle/handle.rb:46:in `raw_connect_try_ssl'
/var/www/miq/vmdb/gems/pending/openstack/openstack_handle/handle.rb:170:in `connect'
/var/www/miq/vmdb/app/models/manageiq/providers/openstack/manager_mixin.rb:60:in `connect'
/var/www/miq/vmdb/app/models/manageiq/providers/openstack/base_metrics_capture.rb:29:in `block in perf_init_openstack'
/var/www/miq/vmdb/gems/pending/util/extensions/miq-benchmark.rb:11:in `realtime_store'
/var/www/miq/vmdb/gems/pending/util/extensions/miq-benchmark.rb:30:in `realtime_block'
/var/www/miq/vmdb/app/models/manageiq/providers/openstack/base_metrics_capture.rb:28:in `perf_init_openstack'
/var/www/miq/vmdb/app/models/manageiq/providers/openstack/base_metrics_capture.rb:13:in `perf_collect_metrics'
/var/www/miq/vmdb/app/models/metric/ci_mixin/capture.rb:6:in `perf_collect_metrics'
/var/www/miq/vmdb/app/models/metric/ci_mixin/capture.rb:157:in `block in perf_capture'
/var/www/miq/vmdb/gems/pending/util/extensions/miq-benchmark.rb:11:in `realtime_store'
/var/www/miq/vmdb/gems/pending/util/extensions/miq-benchmark.rb:30:in `realtime_block'
/var/www/miq/vmdb/app/models/metric/ci_mixin/capture.rb:154:in `perf_capture'
/var/www/miq/vmdb/app/models/metric/ci_mixin/capture.rb:94:in `perf_capture_realtime'

Comment 3 Nandini Chandra 2016-08-09 19:32:16 UTC
Tested both OSP 6 and OSP 7.

Comment 6 Greg Blomquist 2016-08-09 21:07:06 UTC

*** This bug has been marked as a duplicate of bug 1365560 ***

Comment 7 Nandini Chandra 2016-08-10 20:09:13 UTC
Clearing NEEDINFO

Comment 8 Marek Aufart 2016-10-14 11:35:21 UTC
This starts looking not to be a dupe of BZ1365560.

@Nandini, would it be possible get Ceilometer log entries from point when it returned 406 response or provide Fog log with enabled debug with more detailed information?

Comment 9 Nandini Chandra 2017-01-20 19:46:29 UTC
Hi Marek,

Unfortunately, I don't have the appliance on which this issue was seen.

Comment 12 Ronnie Rasouli 2017-05-17 07:26:22 UTC
tested on 5.8.0.14 , metrics can be collected properly from nodes


Note You need to log in before you can comment on or make changes to this bug.