Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365322 - 4.0 HA agent on NGN is not listed in hosted-engine --vm-status (3.6 SHE RHEVH-EL7 FC-luns env)
Summary: 4.0 HA agent on NGN is not listed in hosted-engine --vm-status (3.6 SHE RHEVH...
Keywords:
Status: CLOSED DUPLICATE of bug 1364034
Alias: None
Product: ovirt-hosted-engine-ha
Classification: oVirt
Component: Agent
Version: 2.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
urgent vote
Target Milestone: ---
: ---
Assignee: Martin Sivák
QA Contact: Ilanit Stein
URL:
Whiteboard:
Depends On:
Blocks: 1319457
TreeView+ depends on / blocked
 
Reported: 2016-08-08 23:25 UTC by Jiri Belka
Modified: 2016-08-09 08:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-09 07:15:53 UTC
oVirt Team: SLA
gklein: ovirt-4.0.z?
gklein: blocker?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

Description Jiri Belka 2016-08-08 23:25:13 UTC
Description of problem:

4.0 NGN (d/s) was added to existing 3.6 SHE setup (RHEVH 3.6 EL7) with FC luns, although 4.0 NGN is not listed in hosted-engine --vm-status. But it is visible in Admin Portal but not "marked" as HE host (General subtab - Hosted Engine HA: Not Active).

This block ongoing migration of the env to 4.0.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. 3.6 RHEVH-EL7 with FC luns (engine is appliance)
2. add 4.0 NGN host via hosted-engine --deploy
3. hosted-engine --vm-status

Actual results:
new 4.0 NGN not present in hosted-engine --vm-status output

Expected results:
should be visible in the hosted-engine --vm-status

Additional info:
hosted-engine --vm-start has started HE VM successfully on 4.0 NGN host

Comment 1 Jiri Belka 2016-08-08 23:27:01 UTC
ovirt-hosted-engine-ha-2.0.1-1.el7ev.noarch

[INFO] You are on rhvh-4.0-0.20160803.0+1

Comment 3 Jiri Belka 2016-08-08 23:35:37 UTC
Strange stuff in logs:

MainThread::ERROR::2016-08-09 02:31:55,679::agent::205::ovirt_hosted_engine_ha.agent.agent.Agent::(_run_agent) Error: ''Configuration value not found: file=/var/lib/ovirt-hosted-engine-ha/ha.conf, key=local_maintenance'' - trying to restart agent

# cat /var/lib/ovirt-hosted-engine-ha/ha.conf 
local_maintenance=False

Comment 4 Simone Tiraboschi 2016-08-09 07:15:53 UTC
Closing this as duplicate of rhbz#1364034 as for comment 3.
Plese see https://bugzilla.redhat.com/show_bug.cgi?id=1364034#c12

*** This bug has been marked as a duplicate of bug 1364034 ***

Comment 5 Jiri Belka 2016-08-09 08:00:19 UTC
(In reply to Simone Tiraboschi from comment #4)
> Closing this as duplicate of rhbz#1364034 as for comment 3.
> Plese see https://bugzilla.redhat.com/show_bug.cgi?id=1364034#c12
> 
> *** This bug has been marked as a duplicate of bug 1364034 ***

Adjusting permissions works fine, thx.


Note You need to log in before you can comment on or make changes to this bug.