Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365303 - [ded-int-gcp] Unable to docker pull from any repository
Summary: [ded-int-gcp] Unable to docker pull from any repository
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Website
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jonathan Yu
QA Contact: Yanping Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 21:05 UTC by Fabiano Franz
Modified: 2016-10-04 13:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-04 13:06:35 UTC


Attachments (Terms of Use)
Build logs from successful build run (deleted)
2016-09-19 20:43 UTC, Jonathan Yu
no flags Details

Description Fabiano Franz 2016-08-08 21:05:49 UTC
Description of problem:

Build always fail in ded-int-gcp with the following logs. The same steps finish successfully when running in a local cluster.

Trying to pull repository registry.access.redhat.com/centos ... failed
Trying to pull repository registry.qe.openshift.com/centos ... failed
Trying to pull repository docker.io/library/centos ... failed
F0808 16:27:04.805234       1 builder.go:204] Error: build error: manifest unknown: manifest unknown

Context: using the Vert.x s2i

Version-Release number of selected component (if applicable): v3.2.1.9-1-g2265530 in ded-int-gcp

How reproducible: always

Steps to Reproduce:
1. Create a new project
2. oc create -f https://raw.githubusercontent.com/vert-x3/vertx-openshift-s2i/master/vertx-s2i-all.json
3. oc start-build vertx-s2i --follow

Actual results: Build exit with errors

Expected results: Builder image for Vert.x should have been built 

Additional info: The same steps finish successfully when running in a local cluster.

Comment 1 mdong 2016-08-09 02:11:33 UTC
It looks the same issue with https://bugzilla.redhat.com/show_bug.cgi?id=1346167

Comment 2 Jonathan Yu 2016-09-07 22:20:19 UTC
Cannot reproduce the issue at the moment because I'm blocked by a problem with the environment.  Ops is preparing to upgrade OSE versions and believe it will resolve the issue.

Error message:

Error syncing pod, skipping: failed to "StartContainer" for "POD" with ErrImagePull: "image pull failed for registry.ops.openshift.com/openshift3/ose-pod:v3.2.1.9, this may be because there are no credentials on this request. details: (Error: image openshift3/ose-pod:v3.2.1.9 not found)"

Comment 3 Jonathan Yu 2016-09-19 20:43:24 UTC
Created attachment 1202626 [details]
Build logs from successful build run

Comment 4 Jonathan Yu 2016-09-19 20:45:32 UTC
I cannot reproduce this issue following the upgrade of ded-int-gcp. Logs of a successful build execution are attached. It's possible that the vertx-s2i image was pushed with docker-1.10 (using the v2 schema) by mistake, and that it was subsequently updated back (pushing with docker-1.9 or by forcing the v1 schema)

Comment 5 Abhishek Gupta 2016-09-19 20:47:30 UTC
We'll let QE verify this.

Comment 6 Bing Li 2016-09-20 05:47:57 UTC
Build can finish successfully in ded-int-gcp in my test:

$ oc create -f https://raw.githubusercontent.com/vert-x3/vertx-openshift-s2i/master/vertx-s2i-all.json
$ oc get pod
NAME                READY     STATUS      RESTARTS   AGE
vertx-s2i-1-build   0/1       Completed   0          12m
$ oc logs -f vertx-s2i-1-build
....
Successfully built 81861c02bb6b
I0920 01:35:24.289183       1 docker.go:118] Pushing image 172.30.38.247:5000/bingli005/vertx-s2i:latest ...
I0920 01:43:07.549820       1 docker.go:122] Push successful

Move to verified


Note You need to log in before you can comment on or make changes to this bug.