Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365302 - UI request fails with "Error caught: [ArgumentError] comparison of Array with Array failed" error
Summary: UI request fails with "Error caught: [ArgumentError] comparison of Array with...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.5.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: GA
: 5.7.0
Assignee: Gregg Tanzillo
QA Contact: Dave Johnson
URL:
Whiteboard: configuration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 21:05 UTC by Thomas Hennessy
Modified: 2017-12-05 15:47 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-31 13:44:22 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)
current logs with level_rails debug active and two reproductions of fatal error (deleted)
2016-08-08 21:05 UTC, Thomas Hennessy
no flags Details
current logs from customer after executing provided script. Logs should contain evidence that the orignally reported problem persists. (deleted)
2016-08-10 13:27 UTC, Thomas Hennessy
no flags Details

Description Thomas Hennessy 2016-08-08 21:05:12 UTC
Created attachment 1188915 [details]
current logs with level_rails debug active and two reproductions of fatal error

Description of problem:
Fatal error presented when attempting to visualize VMs with VMDB explorer

Version-Release number of selected component (if applicable):
Version: 5.5.5.4

How reproducible:


Steps to Reproduce: not attempted due to environment size
1.
2.
3.

Actual results:
Fatal error with message indicated in summary field

Expected results:
normal return of selected elements to UI worker for display.

Additional info:
UI worker is associated with large CFME rollup region.  Counts from last startup indicate > 22,000 VMs as follows:
=====
[----] I, [2016-07-31T12:15:07.699692 #2796:b97990]  INFO -- : MIQ(MiqRegion.atStartup) Region: [99], name: [Region 99], Under Management: VMs: [22128], Hosts: [2202], Sockets: [4634]
[----] I, [2016-07-31T12:15:07.810022 #2796:b97990]  INFO -- : MIQ(MiqRegion.atStartup) Region: [99], name: [Region 99], Not Under Management: VMs: [1758], Hosts: [61], Sockets: [166]
=====

current logs with rails debug  logging active are provided as attachment.

Comment 2 Harpreet Kataria 2016-08-09 13:01:15 UTC
Gregg,

This looks like a dup of https://bugzilla.redhat.com/show_bug.cgi?id=1284703, sending it your way for investigation.

Thanks,
~Harpreet

Comment 7 Thomas Hennessy 2016-08-10 13:27:32 UTC
Created attachment 1189628 [details]
current logs from customer after executing provided script.  Logs should contain evidence that the orignally reported problem persists.


Note You need to log in before you can comment on or make changes to this bug.