Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365273 - Unable to set IP address for EC2 instance during provisioning
Summary: Unable to set IP address for EC2 instance during provisioning
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.6.0
Hardware: All
OS: All
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Greg McCullough
QA Contact:
URL:
Whiteboard: ec2:provision:cloud-init
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 18:55 UTC by Josh Carter
Modified: 2018-01-05 23:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-28 14:46:51 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Comment 3 Brandon Dunne 2016-08-08 20:39:10 UTC
Extra attributes can be merged into the clone_options hash.  See https://bugzilla.redhat.com/show_bug.cgi?id=1152737 for more details.  Also, I updated the talk article with this comment.

Comment 4 Brandon Dunne 2016-08-22 18:29:54 UTC
Josh, does this resolve the issue?

Comment 6 Brandon Dunne 2017-05-10 14:16:47 UTC
It seems that a static IP address can not be configured through cloudinit on Amazon.  Amazon will only honor it if the address is sent in our clone options.

Also, I don't know exactly what the use case is for setting a static IP address in Amazon.  I would expect floating IPs to be used instead, so there may be conflicts that we need to be aware of.


Here is where the clone options are configured:
https://github.com/ManageIQ/manageiq-providers-amazon/blob/master/app/models/manageiq/providers/amazon/cloud_manager/provision/cloning.rb#L11-L49

Comment 7 Chris Pelland 2017-08-28 14:46:51 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.