Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365269 - [RFE] katello-service does not account for pulp_streamer
Summary: [RFE] katello-service does not account for pulp_streamer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Infrastructure
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: 6.2
Assignee: Stephen Benjamin
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1320751 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 18:34 UTC by Craig Donnelly
Modified: 2018-12-06 20:49 UTC (History)
12 users (show)

Fixed In Version: katello-3.0.0-14
Doc Type: Bug Fix
Doc Text:
Previously Katello services would not restart the pulp_streamer service, which is part of Red Hat Satellite 6. This needed to be stopped and started manually. With this release, this is now controlled with the wrapper script.
Clone Of:
Environment:
Last Closed: 2016-10-26 12:26:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2108 normal SHIPPED_LIVE Satellite 6.2.3 Async Bug Release 2016-10-26 16:21:52 UTC
Foreman Issue Tracker 16373 None None None 2016-09-29 21:02:36 UTC

Description Craig Donnelly 2016-08-08 18:34:02 UTC
Description of problem:

katello-service does not check status, start, or stop 'pulp_streamer' (required for on_demand pulp use).

  7 SERVICES = {
  8   'mongod'                => 5,
  9   'postgresql'            => 5,
 10   'qpidd'                 => 10,
 11   'qdrouterd'             => 10,
 12   'tomcat'                => 20,
 13   'tomcat6'               => 20,
 14   'pulp_workers'          => 20,
 15   'pulp_celerybeat'       => 20,
 16   'pulp_resource_manager' => 20,
 17   'foreman-proxy'         => 20,
 18   'httpd'                 => 30,
 19   'foreman-tasks'         => 30
 20 } 


Version-Release number of selected component (if applicable):

Satellite 6.2.0
----
# rpm -qf `which katello-service`
katello-service-3.0.0-10.el7sat.noarch

How reproducible:
Always.

Steps to Reproduce:
1. # katello-service status
2. Read.
3.

Actual results:
No mention of 'pulp_streamer'.

Expected results:
'pulp_streamer' should be controlled with other required pulp services.

Additional info:
If this service is not started with the rest while a Satellite is using the 'on_demand' setting for pulp syncs, customers will be met with 500 internal server errors on Satellite for attempted client pulls for packages, and the clients get no more mirrors to try.

Comment 1 Craig Donnelly 2016-08-08 18:36:09 UTC
This will also help in troubleshooting for people who are not yet familiar with this service or its job, as we will see the status (good or bad) and que up questions.

Comment 3 Chris Roberts 2016-09-10 03:24:14 UTC
*** Bug 1320751 has been marked as a duplicate of this bug. ***

Comment 4 Chris Roberts 2016-09-16 17:46:34 UTC
Hi,

This is in upstream :

https://github.com/Katello/katello-packaging/blob/master/katello/katello-service

Moving to POST

- Chris Roberts

Comment 5 Zach Huntington-Meath 2016-09-29 20:56:33 UTC
Connecting redmine issue http://projects.theforeman.org/issues/16373 from this bug

Comment 8 jcallaha 2016-10-11 19:10:56 UTC
Verified in Satellite 6.2.3 Snap 2.

pulp_streamer now included in service status output

Redirecting to /bin/systemctl status  pulp_streamer.service
● pulp_streamer.service - The Pulp lazy content loading streamer
   Loaded: loaded (/usr/lib/systemd/system/pulp_streamer.service; enabled; vendor preset: disabled)
   Active: active (running) since Mon 2016-10-10 14:34:21 EDT; 24h ago
 Main PID: 10451 (pulp_streamer)
   Memory: 17.6M
   CGroup: /system.slice/pulp_streamer.service
           └─10451 /usr/bin/python /usr/bin/pulp_streamer --nodaemon --syslog --prefix=pulp_streamer --pidfile= --python /usr/share/pulp/wsgi/streamer.tac

Oct 11 10:52:25 rhsm-qe-1.rhq.lab.eng.bos.redhat.com pulp_streamer[10451]: nectar.downloaders.threaded:ERROR: Skipping requests to cdn.redhat.com due to repeated connection failures: [Errno 2] No such file or directory
Oct 11 10:52:25 rhsm-qe-1.rhq.lab.eng.bos.redhat.com pulp_streamer[10451]: [-] 127.0.0.1 - - [11/Oct/2016:14:52:24 +0000] "GET /var/lib/pulp/content/units/rpm/58/394f78b13325ed4c43fc383ba18180213e19474645da18202ef69c73374a47/openoffice.org-langpack-pl_PL-3.1.1-19.10.el5_8.4.x86_64.rpm HTTP/1.1" 503 - "-" "python-requests/2.6.0 CPython/2.7.5 Linux/3.10.0-327.el7.x86_64"
Oct 11 10:52:25 rhsm-qe-1.rhq.lab.eng.bos.redhat.com pulp_streamer[10451]: nectar.downloaders.threaded:ERROR: Skipping requests to cdn.redhat.com due to repeated connection failures: [Errno 2] No such file or directory
Oct 11 10:52:25 rhsm-qe-1.rhq.lab.eng.bos.redhat.com pulp_streamer[10451]: [-] 127.0.0.1 - - [11/Oct/2016:14:52:24 +0000] "GET /var/lib/pulp/content/units/rpm/8c/579b8c8645040f2514e78f7a72e656a311f8bbf6faa8cddc52b68ffac99187/openoffice.org-langpack-bg_BG-3.1.1-19.10.el5_8.4.x86_64.rpm HTTP/1.1" 503 - "-" "python-requests/2.6.0 CPython/2.7.5 Linux/3.10.0-327.el7.x86_64"
Oct 11 12:10:46 rhsm-qe-1.rhq.lab.eng.bos.redhat.com pulp_streamer[10451]: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (10544): cdn.redhat.com
Oct 11 12:10:46 rhsm-qe-1.rhq.lab.eng.bos.redhat.com pulp_streamer[10451]: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (10545): cdn.redhat.com
Oct 11 12:10:46 rhsm-qe-1.rhq.lab.eng.bos.redhat.com pulp_streamer[10451]: nectar.downloaders.threaded:ERROR: Skipping requests to cdn.redhat.com due to repeated connection failures: [Errno 2] No such file or directory
Oct 11 12:10:46 rhsm-qe-1.rhq.lab.eng.bos.redhat.com pulp_streamer[10451]: [-] 127.0.0.1 - - [11/Oct/2016:16:10:46 +0000] "GET /var/lib/pulp/content/units/distribution/69/d78ad016215bf746c8bd4449ab63aef5cec67df24d763040500cd82dc23dc9/images/pxeboot/initrd.img HTTP/1.1" 503 - "-" "Wget/1.14 (linux-gnu)"
Oct 11 12:10:46 rhsm-qe-1.rhq.lab.eng.bos.redhat.com pulp_streamer[10451]: nectar.downloaders.threaded:ERROR: Skipping requests to cdn.redhat.com due to repeated connection failures: [Errno 2] No such file or directory
Oct 11 12:10:46 rhsm-qe-1.rhq.lab.eng.bos.redhat.com pulp_streamer[10451]: [-] 127.0.0.1 - - [11/Oct/2016:16:10:46 +0000] "GET /var/lib/pulp/content/units/distribution/69/d78ad016215bf746c8bd4449ab63aef5cec67df24d763040500cd82dc23dc9/images/pxeboot/vmlinuz HTTP/1.1" 503 - "-" "Wget/1.14 (linux-gnu)"

Comment 10 errata-xmlrpc 2016-10-26 12:26:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2108

Comment 11 Andrew Dahms 2017-10-05 00:37:59 UTC
Updated 'Doc Type'.


Note You need to log in before you can comment on or make changes to this bug.