Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365256 - xfsprogs: post-4.5.0 fixes, primarily quota-related.
Summary: xfsprogs: post-4.5.0 fixes, primarily quota-related.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xfsprogs
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Eric Sandeen
QA Contact: Zorro Lang
URL:
Whiteboard:
: 1362101 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 17:37 UTC by Eric Sandeen
Modified: 2016-11-04 06:24 UTC (History)
4 users (show)

Fixed In Version: xfsprogs-4.5.0-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 06:24:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2431 normal SHIPPED_LIVE xfsprogs bug fix and enhancement update 2016-11-03 14:00:51 UTC

Description Eric Sandeen 2016-08-08 17:37:06 UTC
We rebased xfsprogs to 4.5.0 for RHEL7.3, but there are several post-4.5.0 fixes now released in 4.7.0, which I would ilke to pick up.

Most are quota related, and fix issues with the new GETNEXTQUOTA functionality we added in this release:

43633a3 xfs: wire up Q_XGETNEXTQUOTA / get_nextdqblk
cef37d5 xfs_quota: fully support users and groups beginning with digits
3d607a1 xfs_quota: print quota id number if the name can't be found
a8b6f52 xfs_quota: check report_mount return value
f61be1b xfs_quota: only round up timer reporting > 1 day
52e81d7 xfs_quota: fall back silently if XFS_GETNEXTQUOTA fails

There are a few other minor updates whihc would be good to get in as well:

6aa32b4 xfs_repair: fix agf limit error messages
027e6ef xfs_db: defang frag command
643f6ac xfs_repair: set rsumino version to 2
70a4820 xfs_repair: low memory shouldn't indicate corruption on exit

Comment 2 Eric Sandeen 2016-08-16 15:47:41 UTC
*** Bug 1362101 has been marked as a duplicate of this bug. ***

Comment 6 Eric Sandeen 2016-09-01 13:27:15 UTC
Done, sorry for the delay.

Comment 9 errata-xmlrpc 2016-11-04 06:24:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2431.html


Note You need to log in before you can comment on or make changes to this bug.