Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365209 - pglogical replication fails to start after migration
Summary: pglogical replication fails to start after migration
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.6.2
Assignee: Nick Carboni
QA Contact: luke couzens
URL:
Whiteboard: black:upgrade:replication
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 15:45 UTC by luke couzens
Modified: 2016-08-16 21:29 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-16 21:29:41 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Comment 2 Nick Carboni 2016-08-15 20:23:12 UTC
This looks like it will be fixed by https://github.com/ManageIQ/manageiq/pull/10124

I can see the following in the postgres log which indicates that we failed the initial data sync which is not recoverable:

2016-08-08 15:34:11 GMT:[local]:57a8a673.7ac3:[unknown]@[unknown]:[31427]:LOG:  connection received: host=[local]
2016-08-08 15:34:11 GMT:[local]:57a8a673.7ac3:root@vmdb_production:[31427]:LOG:  connection authorized: user=root database=vmdb_production
2016-08-08 15:34:11 GMT:[local]:57a8a673.7ac3:root@vmdb_production:[31427]:ERROR:  duplicate key value violates unique constraint "index_cloud_subnets_network_ports"
2016-08-08 15:34:11 GMT:[local]:57a8a673.7ac3:root@vmdb_production:[31427]:DETAIL:  Key (cloud_subnet_id, network_port_id)=(2, 1) already exists.
2016-08-08 15:34:11 GMT:[local]:57a8a673.7ac3:root@vmdb_production:[31427]:CONTEXT:  COPY cloud_subnets_network_ports, line 1
2016-08-08 15:34:11 GMT:[local]:57a8a673.7ac3:root@vmdb_production:[31427]:STATEMENT:  COPY "public"."cloud_subnets_network_ports" FROM stdin
2016-08-08 15:34:11 GMT:[local]:57a8a673.7ac3:root@vmdb_production:[31427]:ERROR:  current transaction is aborted, commands ignored until end of transaction block
2016-08-08 15:34:11 GMT:[local]:57a8a673.7ac3:root@vmdb_production:[31427]:STATEMENT:  COPY "public"."git_references" FROM stdin
2016-08-08 15:34:11 GMT::57a8a673.7ac2:@:[31426]:ERROR:  table copy failed
2016-08-08 15:34:11 GMT::57a8a673.7ac2:@:[31426]:DETAIL:  Query 'COPY "public"."git_references" FROM stdin':
2016-08-08 15:34:11 GMT::57a8a4c5.7379:@:[29561]:LOG:  worker process: pglogical apply 16386:1658409966 (PID 31426) exited with exit code 1
2016-08-08 15:34:11 GMT::57a8a673.7ac4:@:[31428]:ERROR:  subscriber region_0_subscription initialization failed during nonrecoverable step (d), please try the setup again


I can also see the following contents of the cloud_subnets_network_ports table which also would indicate the same issue.

vmdb_production=# select * from cloud_subnets_network_ports;
       id       | cloud_subnet_id | network_port_id | address 
----------------+-----------------+-----------------+---------
 99000000000001 |               2 |               1 | 
 99000000000002 |               2 |               2 | 
 99000000000003 |               3 |               3 | 
 99000000000004 |               3 |               4 | 
 99000000000005 |               1 |               5 | 
 99000000000006 |               1 |               6 | 
(6 rows)


So this is not *really* a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1361218 but has the same cause.

Can you retest with build 5.6.1.2 which should have the fix? Thanks!

Comment 3 luke couzens 2016-08-16 21:29:41 UTC
Hey Nick, you are right this is fixed in 5.6.1.2


Note You need to log in before you can comment on or make changes to this bug.